Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-09-2016, 09:21 PM   #1
Senior Member
 
bandorr2000's Avatar


 
Join Date: Aug 2015
Location: Cinnaminson, NJ
Posts: 194
Inverter problem?

Noticed this yesterday. When disconnecting from shore power, and inverter on, one night light along with the clock display are blinking off and on. Didn't look, but I'll assume the refrigerator would also be affected. Any ideas? Stopped after starting engine, possible battery problem? Magnum 2000 watt inverter.
__________________

__________________
GlennD
2014 THOR PALAZZO 35.1
2015 Equinox Toad
bandorr2000 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-09-2016, 10:05 PM   #2
Senior Member
 
Tiffin Owners Club
Appalachian Campers
Mid Atlantic Campers
Coastal Campers
Freightliner Owners Club
Join Date: Jan 2015
Posts: 414
Check your house batteries, and cable connections. Also, what is the voltage on your battery bank when you have this problem?


When you start the engine, the alternator is supplying a higher voltage to charge both the chassis and house batteries. The fact that your symptom disappear at this point, leads me to believe your house battery bank has an issue.
__________________

__________________
DaveB, Raleigh, NC
2015 Tiffin RED 33AA
2014 Honda CRV
Kiawah is online now   Reply With Quote
Old 10-14-2016, 09:10 AM   #3
Senior Member
 
bandorr2000's Avatar


 
Join Date: Aug 2015
Location: Cinnaminson, NJ
Posts: 194
Disconnected batteries, house batteries have 6.xxx volts each, chassis batteries are 13.xxx. Saw no difference with house batts when inverter turned on and no external AC from any source. Will have dealer check inverter when it goes up there next week.
__________________
GlennD
2014 THOR PALAZZO 35.1
2015 Equinox Toad
bandorr2000 is offline   Reply With Quote
Old 10-15-2016, 09:59 AM   #4
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 16,621
If the inverter works fine with the engine running, you don't have an inverter issue. Got to be the 12v source (house batteries).

What did the Magnum display say when those things were blinking? Was it still on, or had it faulted. And what fault did it indicate?
__________________
Gary Brinck
2004 American Tradition; 2014 Buick LaCRosse
Homebase in the Ocala Nat'l Forest near Ocala, FL
Gary RVRoamer is offline   Reply With Quote
Old 10-15-2016, 10:35 AM   #5
Senior Member
 
Tiffin Owners Club
Appalachian Campers
Mid Atlantic Campers
Coastal Campers
Freightliner Owners Club
Join Date: Jan 2015
Posts: 414
I think you have a Magnum inverter, check for a tripped fuse on the inverter.
__________________
DaveB, Raleigh, NC
2015 Tiffin RED 33AA
2014 Honda CRV
Kiawah is online now   Reply With Quote
Old 10-15-2016, 11:24 AM   #6
Senior Member
 
CountryFit's Avatar
 
Join Date: Sep 2011
Location: Between Oceans
Posts: 2,734
believe your inverter is of no issues but the house batteries might. you said it's 6.xx, what are the decimals? 6.5 or higher is fine; 6.05 or lower is below 50%. check it out carefully.
__________________
2000 Country Coach Intrigue 40'
CountryFit is online now   Reply With Quote
Old 10-15-2016, 04:32 PM   #7
Senior Member
 
bandorr2000's Avatar


 
Join Date: Aug 2015
Location: Cinnaminson, NJ
Posts: 194
House batts were 6.7 something on all 4. Will have to watch display on remote, will do tomorrow.


2014 Thor Palazzo 35.1
Sent from my iPhone using iRV2 - RV Forum
__________________
GlennD
2014 THOR PALAZZO 35.1
2015 Equinox Toad
bandorr2000 is offline   Reply With Quote
Old 10-16-2016, 10:23 AM   #8
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 16,621
6v batteries, I hope?
__________________
Gary Brinck
2004 American Tradition; 2014 Buick LaCRosse
Homebase in the Ocala Nat'l Forest near Ocala, FL
Gary RVRoamer is offline   Reply With Quote
Old 10-16-2016, 10:33 AM   #9
Senior Member
 
jharrell's Avatar
 
Join Date: Jan 2014
Location: Safety Harbor, FL
Posts: 533
Sounds like its in search mode. If there is not enough load like just night light and clock it will cycle on and off to save power. I turned off search mode on mine because it would cause the microwave to blink on and off, just manually turn the inverter on/off as needed instead.

If I remember it needs 5 watt load to get out of search, check search watts setting under inverter setup on remote.
__________________
2016 Winnebago Vista 31be - Blue Ox Rear Track Bar - Centramatic Wheel balancers
2016 Jeep Wrangler Unlimited Rubicon Toad - Readybrute Elite Towbar
jharrell is offline   Reply With Quote
Old 10-16-2016, 12:58 PM   #10
Senior Member
 
bandorr2000's Avatar


 
Join Date: Aug 2015
Location: Cinnaminson, NJ
Posts: 194
Refrigerator on, sorry, clock is on microwave. Yes, 6 volt batts


2014 Thor Palazzo 35.1
Sent from my iPhone using iRV2 - RV Forum
__________________
GlennD
2014 THOR PALAZZO 35.1
2015 Equinox Toad
bandorr2000 is offline   Reply With Quote
Old 10-16-2016, 01:07 PM   #11
Senior Member
 
jharrell's Avatar
 
Join Date: Jan 2014
Location: Safety Harbor, FL
Posts: 533
Fridge cycles on and off, doesn't run constantly. My Absorb fridge draws about 300w when on and would keep the inverter on, but when it cycled off and nothing but a clock or low power light was on it would go into search mode and blink everything. I believe the Magnum remote will say Searching... as well. Sounded so similar to your issue thought it was worth a look.
__________________
2016 Winnebago Vista 31be - Blue Ox Rear Track Bar - Centramatic Wheel balancers
2016 Jeep Wrangler Unlimited Rubicon Toad - Readybrute Elite Towbar
jharrell is offline   Reply With Quote
Old 10-16-2016, 01:09 PM   #12
Senior Member
 
bandorr2000's Avatar


 
Join Date: Aug 2015
Location: Cinnaminson, NJ
Posts: 194
Inverter problem?

Jharrell, you are probably correct


2014 Thor Palazzo 35.1
Sent from my iPhone using iRV2 - RV Forum
__________________
GlennD
2014 THOR PALAZZO 35.1
2015 Equinox Toad
bandorr2000 is offline   Reply With Quote
Old 10-17-2016, 03:14 PM   #13
Senior Member
 
bandorr2000's Avatar


 
Join Date: Aug 2015
Location: Cinnaminson, NJ
Posts: 194
Turned off search mode, no more blinking. Thanks to all who responded.
__________________

__________________
GlennD
2014 THOR PALAZZO 35.1
2015 Equinox Toad
bandorr2000 is offline   Reply With Quote
Reply

Tags
inverter


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing an Inverter in a Coach That Doesn't Have a Factory Inverter vettenuts Newmar Owner's Forum 26 07-08-2014 10:37 AM
Inverter and Inverter Remote Panel Manual EL_Carlson Winnebago Industries Owner's Forum 2 05-01-2011 06:31 PM
inverter/charger or just inverter bdawson11 RV Systems & Appliances 10 06-14-2009 10:48 AM
Simple Inverter Hook Up? Plug my 50 amp to the inverter? E Z Livin MH-General Discussions & Problems 7 12-19-2005 03:59 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.