Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-14-2016, 02:43 PM   #1
Member
 
bruce Dixon's Avatar
 
Join Date: Nov 2013
Location: Hillsboro, Or
Posts: 67
Question Inverter question

I have a 2002 Itasca horizon 39'
It seems that my Inverter is running all my 110 volt systems when disconnected from land source. I have never noticed this happening before. it seems like my batteries are running down a lot quicker. when driving my, 110V systems are all powered up.
Or is this normal??????
__________________

__________________
Bruce , Donna Dixon MSgt. USAF Ret.
Hillsboro, Or.
Itasca Horizon 39QD
bruce Dixon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-14-2016, 02:51 PM   #2
Senior Member
 
Join Date: Jul 2010
Posts: 179
Normal for most coaches with a 2k or bigger inverter to power up all the receptacles (basically all the small loads) Most power everything except the refer, H2O & A/C's. If going dead while driving my guess is the Battery Isolator or Charge Solenoid isn't functioning correctly.
__________________

__________________
InfinityJim is offline   Reply With Quote
Old 03-14-2016, 02:51 PM   #3
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by bruce Dixon View Post
I have a 2002 Itasca horizon 39'
It seems that my Inverter is running all my 110 volt systems when disconnected from land source. I have never noticed this happening before. it seems like my batteries are running down a lot quicker. when driving my, 110V systems are all powered up.
Or is this normal??????
bruce Dixon
It's only normal if the inverter is ON ...(it's not normal if it is turned OFF).
What is the make and model number of your inverter?
Mel
'96 Safari
__________________
mel s is offline   Reply With Quote
Old 03-14-2016, 02:58 PM   #4
Senior Member
 
ecurb74's Avatar
 
Join Date: Feb 2013
Posts: 233
Can you not turn the inverter off on the panel? I turn mine on when needed but my coach is wired to where the coach and chassis batteries are charged while driving plus I have 4 solar panels up top. Some times I'll turn it on while driving if I want to run the microwave.


Bruce & Teresa
2000 Foretravel U320 4010
Cummins ISM 450hp
Allison HD4060R 6 Spd W/Retarder
__________________
Bruce & Teresa
2000 Foretravel
U320 4010
ecurb74 is offline   Reply With Quote
Old 03-14-2016, 03:44 PM   #5
Member
 
bruce Dixon's Avatar
 
Join Date: Nov 2013
Location: Hillsboro, Or
Posts: 67
Well it looks like my xantrex power supply controller lost it's signal. unhooked the connector from the back and replugged it in and now it's working. don't know why this happens or what is causing it. this happened about 2 years ago now that I remember and fixed it then.
__________________
Bruce , Donna Dixon MSgt. USAF Ret.
Hillsboro, Or.
Itasca Horizon 39QD
bruce Dixon is offline   Reply With Quote
Old 03-14-2016, 03:49 PM   #6
Senior Member
 
ecurb74's Avatar
 
Join Date: Feb 2013
Posts: 233
Good deal!

Glad you reported back with a simple fix...mine never seem to run on the simple side. Sometimes electronics need to be rebooted with a total power interruption.


Bruce & Teresa
2000 Foretravel U320 4010
Cummins ISM 450hp
Allison HD4060R 6 Spd W/Retarder
__________________
Bruce & Teresa
2000 Foretravel
U320 4010
ecurb74 is offline   Reply With Quote
Old 03-14-2016, 04:18 PM   #7
Member
 
bruce Dixon's Avatar
 
Join Date: Nov 2013
Location: Hillsboro, Or
Posts: 67
simple fix is unusual for me LOL
__________________

__________________
Bruce , Donna Dixon MSgt. USAF Ret.
Hillsboro, Or.
Itasca Horizon 39QD
bruce Dixon is offline   Reply With Quote
Reply

Tags
inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter and Inverter Remote Panel Manual EL_Carlson Winnebago Industries Owner's Forum 2 05-01-2011 06:31 PM
inverter/charger or just inverter bdawson11 RV Systems & Appliances 10 06-14-2009 10:48 AM
Simple Inverter Hook Up? Plug my 50 amp to the inverter? E Z Livin MH-General Discussions & Problems 7 12-19-2005 03:59 AM
"Fresh" water question, & Inverter/Battery question Dagwood_73 Boondocking 7 07-29-2005 02:15 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.