Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2015, 09:47 PM   #1
Member
 
rickmc's Avatar


 
Join Date: Feb 2013
Location: Rosemount, MN
Posts: 69
Inverter Trouble I Think

Hi All,
I'm plugged into shore power, & this is what my magnum is reading. Looks like the batteries are charging but nothing inverting. I also notice when I was on my way to the campground my magnum was dark. I did not have it in power save mode.
It got warm in the rig so I turned on my generator for the roof air units and the magnum came on!

Battery level indicator on the magnum is showing my batteries are losing strength started with 5 bars down to 3 bars as I type this. Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1441507512.177509.jpg
Views:	88
Size:	298.4 KB
ID:	105981Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1441507561.395960.jpg
Views:	86
Size:	284.1 KB
ID:	105982

I'd appreciate and suggestions.

Thanks,
__________________

__________________
rickmc
Waiting to get back on the road!![SIGPIC]
rickmc is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-05-2015, 09:51 PM   #2
Senior Member
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Aug 2014
Posts: 1,845
The inverter is "ON", but there is no reason for it to actually invert (use the batteries) since you are on shore power.
Turn off the breaker at the power pedestal, and the inverter should kick in for the Fridge, or run the microwave to confirm.

The Remote dispaly goes dark until you push a button to activate the screen lights.

Nothing wrong so far as I can tell.

Regards,

Dan
__________________

__________________
2014 40QBH Phaeton DP Cummins 380HP ISL, Freightliner XC, 2014 Jeep Trailhawk TOAD
Blue Ox Aventa tow bar, SMI Air Force One -South Orange County Ca.
dpinvidic is offline   Reply With Quote
Old 09-05-2015, 09:56 PM   #3
Senior Member


 
Join Date: Aug 2011
Posts: 3,282
Quote:
Originally Posted by rickmc View Post
Hi All,
I'm plugged into shore power, & this is what my magnum is reading. Looks like the batteries are charging but nothing inverting. I also notice when I was on my way to the campground my magnum was dark. I did not have it in power save mode.
It got warm in the rig so I turned on my generator for the roof air units and the magnum came on!

Battery level indicator on the magnum is showing my batteries are losing strength started with 5 bars down to 3 bars as I type this. Attachment 105981Attachment 105982

I'd appreciate and suggestions.

Thanks,

Plugged into shore power, the inverter doesn't need to produce 110 volt power from the batteries....it just "passes it through".

Then you say you started the generator to run the AC.... Why couldn't you run the AC from the shore power ?
__________________
pasdad1 is offline   Reply With Quote
Old 09-05-2015, 10:37 PM   #4
Member
 
rickmc's Avatar


 
Join Date: Feb 2013
Location: Rosemount, MN
Posts: 69
Sorry for my lack of details, I was on the road when I turned the generator on. Thanks guys, will check at pedestal in the am!
__________________
rickmc
Waiting to get back on the road!![SIGPIC]
rickmc is offline   Reply With Quote
Old 09-05-2015, 11:20 PM   #5
Senior Member
 
RVingDutchman's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Apr 2014
Location: B.C.
Posts: 301
Quote:
Originally Posted by rickmc View Post
Sorry for my lack of details, I was on the road when I turned the generator on. Thanks guys, will check at pedestal in the am!
Rick it still does not make much sense what you are trying to do or prove?

If you are checking for problems if the inverter is working the you should unplug the coach from the shore-pedestal do not run the generator and now switch on the inverter and plug something in to one of your plugins (or try them all at sequential times) and see if that works!

Now you are running that appliance of your batteries, of coarse you can try your Microwave and your 120v lighting etc.
Now you should be able to monitor your usage of your amp-hrs on your system monitor. (if you have one) If not you'll likely have level-lights to watch the batt. level of your system.

If that does not work then you have a problem that could be a breaker/reset or blown fuse or wiring issue or ???

But now you have a place to start!
__________________
2000 American Eagle. DS.DP. 40' 350HP ISC. 4 Koni's, 1200W. Solar, EMS, Compost Toilet, LED Lighting, TPMS, Scangauge, + 5'x11' ToyTrailer = Garage =Toolshed = Boathouse = Spare bedroom = Looking for a bigger one!
[SIGPIC][/SIGPIC]
RVingDutchman is offline   Reply With Quote
Old 09-06-2015, 12:46 AM   #6
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 1,719
My inverter has been on for almost 2 years. Just turn off the power at the pedestal and if the clock on the microwave stays on, the inverter is working.
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Old 09-06-2015, 03:50 PM   #7
Member
 
rickmc's Avatar


 
Join Date: Feb 2013
Location: Rosemount, MN
Posts: 69
All,
Shutoff shore breaker at pedestal and magnum remote control panel screen inside coach went blank. Started up Cummins, still dark. Pushed buttons on panel still dark. Although all 110v outlets & lights working & on while cruising down the road.
Remote Control panel lit up when connected to shore or generator power. I have always seen the magnum screen on in any situation prior.
Am I over thinking this? I am OCD with my rig!!! 😎



Rickmc & Moski
2008 Newmar Kountry Star 3910, Cummins ISL 400 HP
__________________
rickmc
Waiting to get back on the road!![SIGPIC]
rickmc is offline   Reply With Quote
Old 09-06-2015, 11:54 PM   #8
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 1,719
I have the same control panel and the only time mine lights up is if I push one of the button then after a little bit all the lights go out, works great.
2 stroker
__________________

__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Reply

Tags
inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnum inverter and Morningstar TriStar Solar controller problems lajuene RV Systems & Appliances 6 08-11-2015 10:48 AM
2004 Sea Breeze....add an inverter Dntsdad National RV Owner's Forum 6 03-16-2015 12:56 AM
Understanding my Inverter wingtip Newmar Owner's Forum 21 02-23-2015 06:59 AM
Inverter install pictures on 2014 Thor ACE 27.1 Forest Grump Thor Industries Owner's Forum 42 01-26-2015 11:37 AM
Freedom 458 inverter voltage fluctuation Oakviewjeff RV Systems & Appliances 2 11-29-2014 10:27 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.