Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-05-2016, 10:40 PM   #1
Senior Member
 
Chiefly1's Avatar
 
Join Date: Nov 2013
Posts: 274
Jacks died

My levelers worked perfect last night but this morning the panel was dead. Suspect a fuse is blown but can't find the sucker. Since I had to move releasing the air brake pulled them up. Anyone have a location of the fuse panel on a Fleetwood Revolution for the jacks? Any ideas or suggestions welcome.


Bill & Christine
40 ft Revolution LE Diesel Pusher & Honda Fit Sport
Sent from my iPad using iRV2 - RV Forum
__________________

__________________
Chiefly1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-06-2016, 03:12 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Fuse should be in the Battery Control Center. A black box approx. 10" square X 6-7" deep.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 04-06-2016, 08:07 AM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 26,200
You scared me there for a second! I clicked on the thread to extend my condolences to Jack's family!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 04-06-2016, 09:18 AM   #4
Community Moderator
 
JMonroe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2009
Location: Deer Creek RV and Golf Resort, Davenport FL
Posts: 6,853
Bill. I'd guess either in one of the fuse boxes in the compartment below the driver's captains chair or in the inverter bay. As the Rev's jacks are powered in both directions (at least they are for 2011) obviously there's nothing wrong with the system at large, I think you're on the right track. A fuse or a controller.

A call to AC, or a note to Debbra Merrit: (debbra.merritt@fleetwoodrv.com) should get you an answer.

Good luck!
__________________
Jay & Peggy Monroe with Dolly
Can't take it with you - don't plan on leaving any behind
2016 Newmar London Aire 4553, Spartan chassis
2017 GMC Acadia toad
JMonroe is offline   Reply With Quote
Old 04-06-2016, 09:32 AM   #5
Senior Member
 
Podivin's Avatar


 
Join Date: Dec 2015
Posts: 1,091
Quote:
Originally Posted by MSHappyCampers View Post
You scared me there for a second! I clicked on the thread to extend my condolences to Jack's family!
I was right there with you!
"oh crap, is that somebody's dog or a man we know here".

OP, I'm sorry for the lose of your fuse.
__________________
1996 Fleetwood Southwind 34'
Podivin is online now   Reply With Quote
Old 04-08-2016, 01:59 AM   #6
Senior Member
 
Chiefly1's Avatar
 
Join Date: Nov 2013
Posts: 274
I sure didn't think about how that "Jacks died" title could have another meaning... My bad! Thanks for the condolences though! The original manual I have is not much help unfortunately as it isn't where they said is was. I've send a note to Deb at AC asking for help in locating the fuse panel. But that came back with an automated reply saying she is out of the office and won't get email. There is a phone number so I'll try that in the morning.
That's for the ideas, suggestions and thoughts. Really appreciated!


Bill & Christine
40 ft Revolution LE Diesel Pusher & Honda Fit Sport
Sent from my iPad using iRV2 - RV Forum
__________________
Chiefly1 is offline   Reply With Quote
Old 04-08-2016, 06:32 PM   #7
Member
 
Join Date: Sep 2010
Posts: 72
Sir, I have a fuse panel in the master bedroom in a cabinet, another fuse block in the right bay door behind right wheel, another fuse block in the bay on the left side just under the drivers area, and six wired fused under the front dash just to the right of the steering wheel. There may be more I just have not found them. Good luck.
__________________
2010 Fleetwood Discovery, Cummins ISB 350, 2016 Jeep Rubicon or 2005 Jeep Rubicon.
jth camper is offline   Reply With Quote
Old 04-09-2016, 12:46 AM   #8
Senior Member
 
Join Date: Mar 2015
Posts: 143
Do you have any lights on at all?
__________________
LINADR is offline   Reply With Quote
Old 04-11-2016, 01:02 PM   #9
Senior Member
 
Chiefly1's Avatar
 
Join Date: Nov 2013
Posts: 274
No lights at all. But I did find the fuse box behind a panel with two fuses for the stabilizers. Fuses looked fine but replaced both with no change at all. Thanks to this forum for the suggestions... Deb from AC replied and sent me a wire diagram for my year coach but unfortunately it's all wrong so they must have changed the wiring at some point mid year. Waiting for Monday for a new version.


Bill & Christine
40 ft Revolution LE Diesel Pusher & Honda Fit Sport
Sent from my iPad using iRV2 - RV Forum
__________________
Chiefly1 is offline   Reply With Quote
Old 04-11-2016, 08:16 PM   #10
Senior Member
 
Join Date: Mar 2015
Posts: 143
I would check the switch attached to the parking brake (if you have one). I'm not familiar with diesels, but on my gasser there's an micro switch that closes when I apply the parking brake. Occasionally it sticks, and won't apply power to the system, giving me no lights. You probably have something similar in your rig.
__________________
LINADR is offline   Reply With Quote
Old 04-11-2016, 10:37 PM   #11
Member
 
gateaux01's Avatar
 
Join Date: Apr 2016
Posts: 98
Linadr may be on the right track, my jacks will not work without the parking brake set. There is a switch on mine as well.
__________________
gateaux01 is offline   Reply With Quote
Old 04-29-2016, 10:16 PM   #12
Member
 
Skino47's Avatar
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Nov 2013
Posts: 44
My 2006 Bounder LevellLegs control has NO POWER but I don't see the park brake SWITCH? Is it inside at the PB pedal? Or below on the brake actuator??

We just had our V10 replaced at Gilbert Truck Ctr of Macon and she runs well now (#9 piston cracked suddenly at 44k miles). GTC did a great job but as I did my pre-check I like to switch ON my Atwood LLegs to see all 4 showing green solid lights confirming all corners full UP. TOUCHING ON = NOTHING, NO POWER?

This thread calls out a park brake micro switch but I don't see it. Park Brake works / releases and operates PB dash icon and propery controls the DRLights (engine ON + PB OFF = DRL ON)

Helllllp!!
Skip & Patty
2006 Bounder 35E 20th Anniv Edition
__________________
Skino47 is offline   Reply With Quote
Old 04-30-2016, 07:08 AM   #13
Member
 
gateaux01's Avatar
 
Join Date: Apr 2016
Posts: 98
Not looking at mine but I think when I engage my brake a button type switch releases. This is inside the cab
__________________
gateaux01 is offline   Reply With Quote
Old 04-30-2016, 08:33 AM   #14
Senior Member
 
krivanj's Avatar


 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Oct 2009
Location: Fort Pierce, FL
Posts: 639
On my Rev LE, even with the brake released, or going down the road in Drive, when I turn on the leveler power, the panel lights up and it beeps at me. That would preclude the brake switch not working. I have Equalizer levelers. With no power at all, I would be thinking a fuse somewhere. It is not hard to take the screen out from the front of the dashboard at the bottom (just pull, velcro) and check if you have voltage to the leveler panel....
__________________

__________________
Revolution LE 38X C9 Cat
2011 Scion TC toad
1985 KLR 600 as a backup...
krivanj is offline   Reply With Quote
Reply

Tags
jacks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnetek/Parallax 6345 converter died after furnace died SatWorld RV Systems & Appliances 26 05-01-2015 07:23 AM
battery died...STILL NEED HELP jrnutpaul Class C Motorhome Discussions 16 09-20-2007 02:41 PM
Chassis Batteries Died Fritzo Class A Motorhome Discussions 8 07-22-2007 12:53 PM
Hi refridgerator died on this trip george & betty RV Systems & Appliances 3 06-11-2007 08:56 PM
Bo Schembechler Died RustyJC Just Conversation 3 11-17-2006 04:30 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.