Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-07-2011, 04:44 PM   #1
Senior Member
 
Join Date: Feb 2011
Posts: 514
Koehler 5000 w Gen.1996

My gen has only 262 hrs on it. It runs and does the job but when I shut it down and leave it off for about 10 min. it refuses to start back up until it cools down. This sounds like a vapor lock problem. Anybody else have or had that problem ? And if so what did you do about it. I pulled the gas line and put it in a can with gas and seafoam but no luck. If its vapor locking I sure dont know what to do about it.
Thanks
__________________

__________________
Don and Maxine McQueen
1996 Damon Intruder
F53 Chassis 33 ft
donandmax is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-07-2011, 08:10 PM   #2
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,383
It is possible you have a leaking float valve. when you shut it off, the fuel leaks pass the shutoff and floods the engine. after it sits a while the gas evaporates and it will start.
__________________

__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is online now   Reply With Quote
Old 07-08-2011, 08:00 AM   #3
Senior Member
 
Join Date: Feb 2011
Posts: 514
Quote:
Originally Posted by ga traveler View Post
It is possible you have a leaking float valve. when you shut it off, the fuel leaks pass the shutoff and floods the engine. after it sits a while the gas evaporates and it will start.
Now that makes sense
Thanks, Don
__________________
Don and Maxine McQueen
1996 Damon Intruder
F53 Chassis 33 ft
donandmax is offline   Reply With Quote
Old 07-09-2011, 08:44 AM   #4
Senior Member
 
Join Date: Feb 2011
Posts: 514
Think I fouund the problem. The electric choke was set pretty much backwards and upon shut down it would go to full choke. Now we all know what happens when a hot engine trys to start while on full choke...Sofar so good.
Thanks for the reply
__________________
Don and Maxine McQueen
1996 Damon Intruder
F53 Chassis 33 ft
donandmax is offline   Reply With Quote
Old 07-09-2011, 09:24 PM   #5
Senior Member
 
Join Date: Feb 2011
Posts: 514
Well besides the choke being off the real culprit was the sparkplugs. The "mechanic" at the dealership set the gap at .045 The book clearly states.025 so the coil and plugs were having a hard time jumping that gap. Mystery solved. Thanks guys appreciate the help.
Don
__________________
Don and Maxine McQueen
1996 Damon Intruder
F53 Chassis 33 ft
donandmax is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My first RV project - 79 Holiday Rambler Imperial 5000 ramblingman Vintage RV's 9 12-24-2010 06:15 PM
Onan 5000 Cranks but no start Wanabee FTer MH-General Discussions & Problems 2 07-27-2010 11:06 AM
Refrigerator not working over 5000 ft SocalHodaka Winnebago Industries Owner's Forum 6 07-27-2009 07:01 PM
Freqency adjustment Onan 5000 Larry Shew Winnebago Industries Owner's Forum 4 06-24-2009 04:37 PM
Home Depot 5000 Watt Generator max49 RV Systems & Appliances 5 06-23-2005 05:25 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.