Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-15-2014, 01:08 PM   #1
Senior Member
 
adonh's Avatar
 
Join Date: Apr 2013
Location: Missouri City, TX
Posts: 1,306
Kwikee Step

Just recently I am getting a popping or clicking sound when the steps close. It seems to happen only when you put weight on the steps after stepping on the top step. Then when you close the door just as they are fully closed there is is one "pop" sound. If you don't put any weight on the steps then this does not happen when they close. I have lubricated the various points that move and it still happens. I can't see anything that would cause this from under the coach. Like I say it just started doing this recently. Any thoughts.
__________________

__________________
Don
2003 Forest River Cardinal Platinum 37' 5th Wheel
1976 31' Airstream
adonh is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-15-2014, 02:43 PM   #2
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,482
IMHO, the most common cause of trouble with these steps is Lubrication or shall we say Lack of.
My first question, what type of Lube did you use?
Some are certainly better than others. I use a spray product that has PTFE which does an effective job of lubrication plus it stays around for a while and does not attract dirt.
So, if you have gone this route and still have the noise, I suspect it is due to a worn or broken pivot bushing underneath. I ended up replacing mine because one of the arms were cracked right at a pivot point. The whole assembly was bent upward. Could not figure out how that could happen but it Looked to me like the previous owner had possibly left something under the step and maybe dumped the air and bent the step upward. In any case, the arm was cracked.
Since replacing, the steps run smoothly in and out.
Hope this helps to get you pointed in the right direction.
__________________

__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is offline   Reply With Quote
Old 03-15-2014, 08:53 PM   #3
Senior Member
 
danleininger's Avatar
 
Newmar Owners Club
Join Date: Feb 2012
Location: Lake Wales, FL (Lake Ashton RV Community)
Posts: 697
Call Kwikee Step Customer Service. They are awesome. I don't have their telephone number but to a Google Search.

Dan
__________________
Dan Leininger
2013 Essex 4547 2017 Ford Expedition 4x4
danleininger is offline   Reply With Quote
Old 03-15-2014, 09:18 PM   #4
Senior Member
 
djbmsu's Avatar
 
Join Date: Nov 2011
Location: Charlotte Harbor, FL
Posts: 1,806
the rubber stops may have worn down or even came off ?
__________________
Don and Nancy
[2014 40QBH Phaeton, 2015 Buick Enclave, 2yr old sisters Sara n Kaycee, Havanese, Two Segways
djbmsu is offline   Reply With Quote
Old 03-17-2014, 04:36 PM   #5
Senior Member
 
adonh's Avatar
 
Join Date: Apr 2013
Location: Missouri City, TX
Posts: 1,306
Its been cold and rainy here for the past 3 days so I have not had a chance to get back to storage and check out the suggestions. The sun is finally out so maybe tomorrow, Thanks
__________________
Don
2003 Forest River Cardinal Platinum 37' 5th Wheel
1976 31' Airstream
adonh is offline   Reply With Quote
Old 03-19-2014, 02:55 PM   #6
Senior Member
 
scenic route's Avatar
 
Join Date: Jan 2010
Posts: 1,767
Check your linkage bolts...

We have triples on the HR. When we stepped on the bottom step, we got some cracking sound. I found a broken bolt at one of the top linkages. It broke right where the bolt shoulder collar and the threads came together. The whole bolt stayed in the hole...the only reason I found it was that after I lubed everything, I checked the tightness of the bolts with a couple of wenches and that one, the thread section just fell off the linkage.

Still have a temp fix on it, thanks for the reminder. Can't find those special bolts anywhere so I guess I'll have to call the company.
__________________
Jan and Bob

RIP 'Squeaky'
scenic route is offline   Reply With Quote
Old 03-19-2014, 05:00 PM   #7
Senior Member
 
adonh's Avatar
 
Join Date: Apr 2013
Location: Missouri City, TX
Posts: 1,306
Quote:
Originally Posted by scenic route View Post
Check your linkage bolts...

We have triples on the HR. When we stepped on the bottom step, we got some cracking sound. I found a broken bolt at one of the top linkages. It broke right where the bolt shoulder collar and the threads came together. The whole bolt stayed in the hole...the only reason I found it was that after I lubed everything, I checked the tightness of the bolts with a couple of wenches and that one, the thread section just fell off the linkage.

Still have a temp fix on it, thanks for the reminder. Can't find those special bolts anywhere so I guess I'll have to call the company.
Still have not made it back to storage but I am going tomorrow so I will check that, thanks
__________________
Don
2003 Forest River Cardinal Platinum 37' 5th Wheel
1976 31' Airstream
adonh is offline   Reply With Quote
Old 03-21-2014, 06:24 PM   #8
Senior Member
 
adonh's Avatar
 
Join Date: Apr 2013
Location: Missouri City, TX
Posts: 1,306
Quote:
Originally Posted by adonh View Post
Still have not made it back to storage but I am going tomorrow so I will check that, thanks
I spend some time yesterday crawling under the and around the step inspecting all of the bolts and moving straps as it opens and closed. I must have open and closed the steps 2o times walking in and out then opening and closing. Then the noise stopped. I have lubed it a few days before but really did not do anything yesterday since everything looked fine. Back at storage today working on projects inside. No noise. So I am not saying it is fixed and may start again, but now its working fine. We will see. Thanks agian for all of the input.

__________________
Don
2003 Forest River Cardinal Platinum 37' 5th Wheel
1976 31' Airstream
adonh is offline   Reply With Quote
Old 03-21-2014, 06:27 PM   #9
Community Administrator
 
Clifftall's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 29,139
Thanks for the update. Glad the noise is gone.
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
Clifftall is offline   Reply With Quote
Old 04-05-2014, 10:40 AM   #10
Junior Member
 
Join Date: Apr 2014
Posts: 6
kwikee step motor/controller upgrade

Hello
I am in the process of upgrading the motor /controller for a Kwikee step. It says if I have a certain controller I will need to upgrade the door switch as well. The current door switch I have is a 3 wire red white black and the new door switch is 2 gray wires. Does one of the wires not get used? Or do I not need to upgrade the switch? If not, can someone provide me with a part # for the 3 wire? Thanks
__________________

__________________
AmEagle04 is offline   Reply With Quote
Reply

Tags
kwikee



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Step motor for series 28 Kwikee Step dnystrom Winnebago Industries Owner's Forum 4 02-28-2014 12:37 PM
Kwikee step question Vtxbiker Alpine Coach Owner's Forum 10 01-15-2014 12:05 AM
Kwikee Step Series 42 01jordyn Country Coach Owners Forum 3 01-11-2014 12:02 PM
Kwikee Step Problem brobox Class A Motorhome Discussions 11 10-29-2013 06:48 PM
Kwikee step problem LJJSRZ Class A Motorhome Discussions 10 08-13-2013 11:07 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.