Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-10-2013, 11:27 AM   #1
Member
 
Teachrz's Avatar
 
National RV Owners Club
Join Date: Jun 2010
Location: Caledonia, MS
Posts: 97
Kwikee step problem

My RV was not used from Thanksgiving to President's day. When I started working in it in January, I noticed that the step retracted every time the door was closed. It did not matter what position the switch was in and the ignition key is out of the ignition. I have removed the switch and it checks fine. Any ideas?
__________________

__________________
Tim Wilcox
Caledonia, MS
1999 National Tropi-Cal V10 - 2008 Volvo C70 toad
Teachrz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-10-2013, 11:51 AM   #2
Senior Member
 
Join Date: Feb 2010
Posts: 4,492
the switch that you turn the steps off is thing to check
__________________

__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 03-10-2013, 12:29 PM   #3
Member
 
Teachrz's Avatar
 
National RV Owners Club
Join Date: Jun 2010
Location: Caledonia, MS
Posts: 97
The switch on the wall tests fine with a test light (hot on one side = switch off, hot on both sides = switch on).
__________________
Tim Wilcox
Caledonia, MS
1999 National Tropi-Cal V10 - 2008 Volvo C70 toad
Teachrz is offline   Reply With Quote
Old 03-10-2013, 12:50 PM   #4
Member
 
esfritzi's Avatar
 
Join Date: Oct 2012
Posts: 94
Did you try to google your problem and see what results come back? or have you contacted Kwikee tech support directly?
__________________
esfritzi is offline   Reply With Quote
Old 03-10-2013, 01:03 PM   #5
Junior Member
 
Join Date: Feb 2013
Posts: 4
Check the connection to the board. Actually check all connections, particularly to ground.
__________________
DMCNEILLY is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.