Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-22-2013, 06:24 AM   #1
Senior Member
60Vette's Avatar
Join Date: May 2012
Location: Tolland, MA/Narragansett, RI
Posts: 159
Laziness Should Not Be Rewarded

However, if someone wants to give me a jump start with my trouble shooting I'm all in.

2002 Freightliner cross country chassis under a Coachmen.

No power to the chassis side accessories. When I flip the chassis rocker to turn on the chassis side battery power the green indicator light will not illuminate nor will it energize the accessories (rear camera, wipers, horn etc.) as it should. When I push the chassis battery rocker switch I hear the relay activating.

New chassis batteries yesterday. The engine fires right up and runs great.

Now it's time to take my test light and determine where the problem is. As soon as I finish my coffee.

60Vette is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-22-2013, 06:30 AM   #2
Senior Member
AttilaKara72's Avatar
Monaco Owners Club
Join Date: Mar 2013
Location: Massachusettes
Posts: 337
I would start right at the switch. If you have power coming into the switch, the switch might need replacing.

1999 Monaco Windsor with a 330 Cummins.
AttilaKara72 is online now   Reply With Quote
Old 08-22-2013, 03:36 PM   #3
Senior Member
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 21,174
Question, IS this switch a 3-position auto return to center rocker or toggle or is it a 2 position (ON/OFF) type.

If On/OFF, skip, If (ON)-OFF-(ON) read on.

My switch failed. IT was the switch.. When I used the DISCONNECT (Store/off) side I clearly heard the latching solenoid CLUNK.. However when I went to re-connect... Nothing.

Knowing a bit about these switches... I removed all power and operated the switch like 50 times, both ways... This cleaned the contacts and ... It has worked fine now for over six years.

THERE IS also a 5 amp fuse on the Intelletec system (It is in the BCC box) that is involved.. I do not know about other systems.
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 08-22-2013, 04:19 PM   #4
Registered User
Join Date: Feb 2013
Posts: 473
After trouble shooting the actual switch,,,

Since your not seeing the accompanying idiot (indicator) light illuminate I would assume the problem is closer to the distribution source as the feedback (indicator) is dim. I'd be trying to manually jump the solenoid IF the batteries are known to be in working condition.
Fl_Richard is offline   Reply With Quote
Old 08-22-2013, 04:55 PM   #5
Winnebago Owners Club
Join Date: May 2004
Location: oak hills ca
Posts: 90
did you check your generator breaker on generator ..on a diesel I had one of the breakers flipped when I was changing out batteries...
Warren Bates
Oak Hills Ca
04 winnebago Brave 30w 8.1/alison
wdbates is offline   Reply With Quote
Old 08-23-2013, 02:42 AM   #6
Community Moderator
RV Wizard's Avatar

Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 11,807
Check fuses and circuit breakers if the disconnect solenoid actually closes the circuit when activated.

Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.