Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2011, 06:54 PM   #1
Junior Member
 
winger01's Avatar
 
Newmar Owners Club
Ford Super Duty Owner
Join Date: Jun 2009
Posts: 14
Levelegs problems

I have a 2006 Scottsale. The levelegs system has been great till now. I can't get the right rear to move. The LED for the right rear keeps flashing green. THe motor appears to be running when I turn the system on. Any body got an idea as to what to check to ge tthe system back up and running
__________________

__________________
Winger01
2006 Scottsdale
winger01 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-05-2011, 07:58 PM   #2
Senior Member
 
Join Date: Sep 2009
Location: Central Indiana
Posts: 328
If you have the manual or go online and download it from Atwood, there is a procedure to manually extend the leg with a wrench. You only need to extend it a little and then it should auto retract. If it doesn't, remove the leg and remove the cover to check the gears. One of them may have a tooth broken. A complete set of gears is about $65.00.
__________________

__________________
mrboyer is offline   Reply With Quote
Old 09-08-2011, 01:32 PM   #3
Junior Member
 
winger01's Avatar
 
Newmar Owners Club
Ford Super Duty Owner
Join Date: Jun 2009
Posts: 14
Thanks for the advice. I contacted Attwood and they told me don't worry just replace the leg at your cost of course. From what I have read that seems to be there answer for everything.
Myabe I can get it back on line again.
Thanks
__________________
Winger01
2006 Scottsdale
winger01 is offline   Reply With Quote
Old 09-08-2011, 03:18 PM   #4
Senior Member
 
Popcorn Man's Avatar
 
Winnebago Owners Club
Join Date: Nov 2009
Location: Chicagoland
Posts: 214
Had my RR Attwood go out last year.Motor would go but leg would not retract. Had to get uder coach manually lift leg up and hook it up with bunge cords so I could get home. Shop had to replace the whole leveler. Wasn't cheap, but thank goodness I have a service contract that covered the cost plus my $200 deductible.
__________________
2012 Winnebago Journey 40U 2013 Chevy Equinox
Popcorn Man is offline   Reply With Quote
Old 09-09-2011, 09:00 AM   #5
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Go to R.R. jack and unplug the motor from the harness. Use 12 volt power to operate the motor and jack manually in both directions. This will reveal if you have a motor or jack mechanism issue. If it checks ok, run all of the legs down manually by this method at least 4" and do a reset; see manual for procedure. Once retracted, I would recommend you do a new zero point reset as well. Keep us posted on the results.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Curious - How Many Problems With Your RV Wayne M iRV2.com General Discussion 39 07-19-2011 07:52 PM
Electrical problems due to switches.. Zbugsii Monaco Owner's Forum 1 06-07-2011 03:19 PM
wiper problems bobeb Newmar Owner's Forum 2 11-07-2010 09:33 PM
Brake Problems lera Alpine Coach Owner's Forum 4 04-05-2009 01:07 PM
Brake Problems, How Likely? supercub Workhorse and Chevrolet Chassis Motorhome Forum 13 11-25-2008 07:55 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.