Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-27-2015, 07:27 PM   #1
Senior Member
Jrf4865's Avatar
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 107
Leveling issue

My leveler system is showing : ERROR retract timeout and then it says return leveler for service. I have only used the system once, new Motorhome, I have a lippert system. Any ideas or do I just need to take it in for service?

Jrf4865 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-27-2015, 07:35 PM   #2
Senior Member
Join Date: Mar 2014
Posts: 170
Same thing happened with my Lippert jacks one time. I called Lippert and they said that often times the ATF in the tank is too low. They recommended to me to ignore the dip stick and add fluid within an inch of top of the tank. I believe that if you hold the down arrow and the next button down for 5 seconds, the system will clear the error code. Going by memory though, so check the manual. I haven't had a problem with the jacks since.

dezrtracr is offline   Reply With Quote
Old 04-27-2015, 07:45 PM   #3
Senior Member
Jrf4865's Avatar
Join Date: Dec 2011
Location: Atlanta, GA
Posts: 107
Thanks, I will try that and give them a call.
Jrf4865 is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake issue? TomJames Alpine Coach Owner's Forum 6 02-20-2015 12:55 PM
Onan generator issue gonefishin77 RV Systems & Appliances 4 01-19-2015 07:48 PM
Overheat issue KJ4ZSI Ford Motorhome Chassis Forum 4 01-02-2015 09:38 PM
Next on the agenda - New front leveling valves ScottRussell Class A Motorhome Discussions 3 01-23-2014 01:40 PM
Strange Electrical Issue baldtat MH-General Discussions & Problems 18 01-13-2014 06:44 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.