Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-05-2013, 10:22 PM   #1
Junior Member
 
Join Date: Mar 2013
Posts: 1
Leveling Jacks

I have a 1997 330 Cat Diesel pusher Allegro Bus with one slide. I only have 23,000 miles. We are full timers. Just recently after coming back to Florida I experienced a problem with my levelers. I parked in a temp spot, leveled the coach, and after 5 days I moved to another space 30 yards away. When I attempted to level the coach the levelers would not go down. I tried auto and manual. All I could hear was 2 clicks and then the control box would shut off. Any suggestion short of C4.
__________________

__________________
gator42 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-06-2013, 03:08 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Hello and We are glad to have you join us here and we look forward to reading of your adventures and experiences. I am sure you will enjoy the website and forums. Good luck, stay safe and keep us posted.
What brand of levelers do you have and have you tried leveling again after the system has had a chance to "cool down" and the battery bank to regain some voltage?
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 03-07-2013, 03:17 PM   #3
Member
 
Join Date: Oct 2010
Posts: 89
Quote:
Originally Posted by gator42 View Post
I have a 1997 330 Cat Diesel pusher Allegro Bus with one slide. I only have 23,000 miles. We are full timers. Just recently after coming back to Florida I experienced a problem with my levelers. I parked in a temp spot, leveled the coach, and after 5 days I moved to another space 30 yards away. When I attempted to level the coach the levelers would not go down. I tried auto and manual. All I could hear was 2 clicks and then the control box would shut off. Any suggestion short of C4.
Mine sometimes get temperamental when I'm on flat ground. All I do is releases the air in the system down below 70 Lbs, then try to level. It usually works.
Also, try locating the pump motor and check the electrical connections that come into it. could be loose or dirty.
__________________
Kent and Sally Lunda
2006 Newmar Mountain Aire 4 Slide 400HP Cummins
2004 Honda Odyssey (Toad)
Kjlunda is offline   Reply With Quote
Old 03-07-2013, 05:04 PM   #4
Senior Member
 
winniman's Avatar
 
Join Date: Jan 2013
Posts: 628
My 37g has hydraulic levelers. The parking brake has to be engaged for them to go down. There is a switch which is activated when you depress the parking brake. Maybe the brake is not pushed down enough or the switch is defective.
__________________
2000 coachmen santara 370 5.9 cummins300 hp isb
winniman is offline   Reply With Quote
Old 03-08-2013, 06:05 PM   #5
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 1,656
Sounds like a dead battery. My power gear controller acts like it's working when this happens, but it's just fooling me. The thing just doesn't work right, then I remember I have an emergency start switch and pushing that makes the thing work.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : http://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Reply

Tags
jacks, leveling



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.