Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-05-2016, 12:33 AM   #1
Junior Member
 
Join Date: May 2015
Posts: 1
Lighting problem on 2001 Mirada 300QB powerhorse chassis

Hi I've had this motorhome for a year now, and it's in pretty nice shape. I've been working on getting some inop items working. There are 2 lights above the dash that have never worked (and spoke to the guy we bought it from and he said they never worked) I checked the obvious, bulbs, switches, but no power to switches. the wires are orange and black, and can't see where they go. Anybody have any ideas? I can't locate even a fuse.
I will also mention that I just replaced a melted ignition switch and plug, and installed a relay to rerout the load. works great.
__________________

__________________
jumpjet55 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-05-2016, 09:48 AM   #2
Senior Member
 
Gormleys's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Sep 2012
Location: CO
Posts: 674
First off, welcome to the forum!

Though I am not familiar with your MH, hopefully someone will recognize your issue and chime in.

You may also want to post it under the "RV Systems & Appliances" section.

Good luck!
__________________
Colorado '15 Winnebago Forza 34T w/MKZ hybrid toad
Gormleys is offline   Reply With Quote
Reply

Tags
ada, chassis, light, mirada, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help! F53 2001 chassis is killing batteries. Coachmen Mirada Kahoona MH-General Discussions & Problems 58 07-25-2016 05:45 PM
2004 Coachmen 300QB Fuse Panel layout? MDW612 Class A Motorhome Discussions 0 05-14-2014 08:49 PM
Coachmen 300qb 2007 should I buy it? davidki Class A Motorhome Discussions 10 02-16-2014 08:53 PM
12V Lighting Problem on 2001 Holiday Rambler Presidential getnstarted RV Systems & Appliances 1 06-20-2011 08:51 AM
Coachmen: Coachmen 2007 300QB davidki Forest River Owners Forum 0 10-23-2010 09:18 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.