Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-06-2016, 01:50 PM   #1
Junior Member
 
Join Date: May 2016
Location: Traveling across USA
Posts: 2
Send a message via Skype™ to Donald.lack
Lost power to hydraulic jacks on Winnebago Vectra

Just lost the power to my control panel for the hydraulic jacks and the rear view back up Camara, it's happened before intermittent then put itself right, l thought it might be due to rear bedroom slide out. Now we have the fault back again and the wing mirrors adjustment has also stopped. Fuses seem OK but l can't think if this is due to an interlock or a bad earth or something else?
Welcome any suggested help or ideas
__________________

__________________
Donald.lack is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-06-2016, 03:41 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,244


You didn't identify brand of leveling system, but with that many things not working and no blown fuses, I suspect a bad ground connection. You could use a jumper wire with alligator clips to create a temporary ground 'work a round' to see if it makes things work again. If it does, trace each ground connection and clean and tighten them.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 11-06-2016, 03:52 PM   #3
Senior Member
 
tomd85208's Avatar
 
Monaco Owners Club
Join Date: Aug 2010
Location: Mesa, Arizona
Posts: 186
Hey Donald.lack, I have the same exact problem, I checked the fuses and there okay, I also replaced the Power Gear control box located in my basement compartment and that didn't help. So I would be VERY interested to see if we can get our coaches figured out. Please let me know if you can figure it out, and I'll also watch for reply's to your post. Thank you!
__________________
Tom & Kathy D.
Mesa Arizona
2007 Monaco Diplomat 40 SKQ
tomd85208 is offline   Reply With Quote
Old 11-07-2016, 04:37 PM   #4
Senior Member
 
tomd85208's Avatar
 
Monaco Owners Club
Join Date: Aug 2010
Location: Mesa, Arizona
Posts: 186
This is the Power Gear Leveling Control box I replaced, but it made no difference, the system still had No Power to the Electronic Touch Pad next to the driver's seat.

IS THERE ANYONE OUT THERE THAT KNOWS HOW TO FIX THIS PROBLEM?
As mentioned above in a previous post.


Thank You!Click image for larger version

Name:	A power gear leveling control #140-1227.jpg
Views:	35
Size:	153.5 KB
ID:	143803
__________________
Tom & Kathy D.
Mesa Arizona
2007 Monaco Diplomat 40 SKQ
tomd85208 is offline   Reply With Quote
Old 11-07-2016, 05:08 PM   #5
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,244
All the things listed as not working are controlled by the ignition switch. It most likely has a relay to power them with ignition on. You could start by finding that first. Also, have you tested the leveling jacks with a 12v + source to see if it works with power? The interlocks that prevent operation while in gear, parking brake off, might be part of the issue, by using a 12v + jumper wire you can eliminate those possibilities.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 11-11-2016, 06:23 PM   #6
Junior Member
 
Join Date: May 2016
Location: Traveling across USA
Posts: 2
Send a message via Skype™ to Donald.lack
Thanks for all the help on my Winnebago Vectra 2007 year diesel, well today we stopped off at Lazydays in Tucson and they couldn't find the fault either and we couldn't stay there until they could go through everything for us. We think it might be the control centre located under the front near the diesel generator. There a control box here with a clear plastic window and inside appears to be relays, fuses and circuit stuff which might be the source of my problems. I am going to go through wiring diagrams and see where the common point is. Then talk to Winnebago technical department and see where it takes me.
__________________

__________________
Donald.lack is offline   Reply With Quote
Reply

Tags
hydraulic, jacks, power, winnebago



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost all 12v power while raising jacks enjoyrv Newmar Owner's Forum 10 06-18-2016 10:47 AM
lost power to slide,jacks controller gatorv Alpine Coach Owner's Forum 4 03-19-2013 11:01 AM
Replace Electric Jacks with Hydraulic Jacks? sidewinder2 5th Wheel Discussion 10 01-04-2011 09:25 PM
2005 Winnebago Voyage-Hydraulic Jacks Fluid Check JC2 Winnebago Industries Owner's Forum 11 01-25-2007 03:42 AM
Lost electrical power to both slides & jacks...Any Ideas ?? Gregg Workhorse and Chevrolet Chassis Motorhome Forum 5 07-13-2005 05:22 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.