Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-25-2015, 10:46 PM   #1
Member
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Iron Station, NC
Posts: 39
Magnum Inverter issues

Need help trouble shooting my inverter. Pulled into RV park today and found that one leg on my 50 amp cord had come lose - repaired that. Now my inverter will not come on to charge. I was using inverter to convert power. Batteries have dropped to 12 volts. I researched the owners manual and it advised to hold the switch on for 5 seconds. Did that and now I have a red fault light on the remote power control panel. I have a battery charger connected in hopes the batteries will charge. Not looking promising at this time. Batteries dropped to 11.2 volts at one time. Back up to 12 volts now. I have a meter and have verified I have 120 volts on the breaker controlling the inverter. 120 volts on each leg of the 50 amp breaker also. Any help on this issue would be helpful as the wife has to use the convection oven tomorrow to help cook Thanksgiving dinner. If I do not get it fixed I will be the turkey. Thanks in advance.


2008 Fleetwood Revolution LE 40E. 400 Cummings Engine
__________________

__________________
2008 Fleetwood Revolution LE - 40E/ Spartan Chaisis
400 Cummings Engine
Toad: Chevrolet 2500 HD
fireinv202 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-25-2015, 11:00 PM   #2
Senior Member
 
Daveht's Avatar


 
Thor Owners Club
Texas Boomers Club
Join Date: May 2015
Location: El Paso TX
Posts: 375
Just a guess. I think there is two push buttons on one end of the inverter that need too be pressed in. They are white in color.

Hope this helps!
__________________

__________________
Dave + Linda
2015 Palazzo 36.1
2010 Honda CR-V toad and Roadmaster Sterling
FMCA F451520 - Texas Boomers - RVM#128
Daveht is offline   Reply With Quote
Old 11-25-2015, 11:28 PM   #3
Senior Member
 
dons2346's Avatar
 
Country Coach Owners Club
Join Date: Dec 2010
Posts: 4,487
Read your manual to find out how to reset the inverter and reset it
__________________
Don
2002 Country Coach Intrigue
dons2346 is offline   Reply With Quote
Old 11-26-2015, 03:23 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
If the neutral conductor is what came loose on the power cord you could have other issues as 220 vac has run it's coarse through the electrical system. What conductor did you have to repair? You should try taking 12 vdc power off the inverter for a minute and then reconnecting. Good luck and keep us posted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 11-26-2015, 12:32 PM   #5
Member
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Iron Station, NC
Posts: 39
Magnum Inverter issues

It was the neutral conductor and the 30 amp side that I repaired. Not sure I know how to take the 12 volt lose. I have it inverting now and using a battery charger. Just cannot get then charger side to work.


2008 Fleetwood Revolution LE 40E. 400 Cummings Engine
__________________
2008 Fleetwood Revolution LE - 40E/ Spartan Chaisis
400 Cummings Engine
Toad: Chevrolet 2500 HD
fireinv202 is offline   Reply With Quote
Old 11-26-2015, 12:35 PM   #6
Member
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Iron Station, NC
Posts: 39
Quote:
Originally Posted by Daveht View Post
Just a guess. I think there is two push buttons on one end of the inverter that need too be pressed in. They are white in color.

Hope this helps!

Checked that. I only have one and it was already pushed in. Apparently never tripped.


2008 Fleetwood Revolution LE 40E. 400 Cummings Engine
__________________
2008 Fleetwood Revolution LE - 40E/ Spartan Chaisis
400 Cummings Engine
Toad: Chevrolet 2500 HD
fireinv202 is offline   Reply With Quote
Old 11-26-2015, 12:46 PM   #7
Senior Member
 
Join Date: Oct 2014
Posts: 326
What is the make and model of inverter / converter? Magnum makes several models.
__________________
msturtz is offline   Reply With Quote
Old 11-26-2015, 03:09 PM   #8
Member
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Iron Station, NC
Posts: 39
Magnum MS2012 is the model.


2008 Fleetwood Revolution LE 40E. 400 Cummings Engine
__________________
2008 Fleetwood Revolution LE - 40E/ Spartan Chaisis
400 Cummings Engine
Toad: Chevrolet 2500 HD
fireinv202 is offline   Reply With Quote
Old 11-26-2015, 03:20 PM   #9
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,267
Blog Entries: 1
Are you getting the OverTemp fault on the display?

Some things to consider. If you let your batteries get really discharged, the charger portion of the inverter may be chugging away at max amps to try and charge them. If you are also asking the inverter to run a lot of stuff (probably not since you are connected to shore power), it may be overheated.

Suggest you do the inverter reset (press and hold the little reset button on the inverter). When it resets (the green LED on the inverter itself should come on), go inside to the remote panel and turn off the inverter (you should not need the inverter anyway if you are on shore power). Then use the settings to lower the charge rate to maybe 50%. It won't charge the batteries as fast but it will do it and produce less heat.

May not fix your issue but might want to give it a try.
__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is offline   Reply With Quote
Old 11-26-2015, 07:45 PM   #10
Member
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Iron Station, NC
Posts: 39
Quote:
Originally Posted by smlranger View Post
Are you getting the OverTemp fault on the display?

Some things to consider. If you let your batteries get really discharged, the charger portion of the inverter may be chugging away at max amps to try and charge them. If you are also asking the inverter to run a lot of stuff (probably not since you are connected to shore power), it may be overheated.

Suggest you do the inverter reset (press and hold the little reset button on the inverter). When it resets (the green LED on the inverter itself should come on), go inside to the remote panel and turn off the inverter (you should not need the inverter anyway if you are on shore power). Then use the settings to lower the charge rate to maybe 50%. It won't charge the batteries as fast but it will do it and produce less heat.

May not fix your issue but might want to give it a try.

What I am getting on the panel is DC OFF. Then it gives me the DC voltage of the batteries. I was able to charge the batteries beyond the threshold of 12.5 doc volts. When I attempt to turn the charger on I get no response. The inverter has been reset to default setting. Still the charger will not come on. I am wondering if I blew one of the overprotection devices on the AC side.


2008 Fleetwood Revolution LE 40E. 400 Cummings Engine
__________________
2008 Fleetwood Revolution LE - 40E/ Spartan Chaisis
400 Cummings Engine
Toad: Chevrolet 2500 HD
fireinv202 is offline   Reply With Quote
Old 12-02-2015, 10:20 PM   #11
Member
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Iron Station, NC
Posts: 39
Well the shop called yesterday and advised the inverter was bad. Guess that explains the issues. I hate to see the bill on this one but it had to be fixed. I guess I will have a rebuilt inverter available real soon. Thanks for all the replys.
__________________
2008 Fleetwood Revolution LE - 40E/ Spartan Chaisis
400 Cummings Engine
Toad: Chevrolet 2500 HD
fireinv202 is offline   Reply With Quote
Old 12-03-2015, 02:45 PM   #12
Senior Member
 
dons2346's Avatar
 
Country Coach Owners Club
Join Date: Dec 2010
Posts: 4,487
If you want a new inverter Boat Supplies, Marine Electronics & Sailing Gear | iMarine USA has the cheapest prices anywhere. You can get either new or rebuilt units.
__________________
Don
2002 Country Coach Intrigue
dons2346 is offline   Reply With Quote
Old 12-03-2015, 04:45 PM   #13
Senior Member
 
Damon Owners Club
Join Date: Jul 2010
Location: Annapolis,MD
Posts: 1,195
Here is some info that may help. Helped me
find a fuse that I never new existed. Also
call them, they often are very helpful.
good luck.
Attached Files
File Type: pdf INVERTER TRBLSHOOT.pdf (121.0 KB, 49 views)
__________________

__________________
macandphyl is offline   Reply With Quote
Reply

Tags
inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What post market inverter did you install? Do you use a remote? Issues you have? TrollMeister Outdoors RV Owner's Forum 4 07-12-2015 07:48 PM
Electrical guidance - inverter issues? jbaker400 Monaco Owner's Forum 5 06-15-2015 11:52 AM
Magnum MS series inverter problem hayward3411 RV Systems & Appliances 26 03-08-2015 10:08 AM
Inverter issues harleypeople RV Systems & Appliances 4 11-15-2014 09:12 AM
Magnum Inverter setup corky.bailey Newmar Owner's Forum 8 11-03-2014 07:09 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.