Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-19-2012, 06:03 PM   #1
Junior Member
Join Date: Sep 2010
Posts: 10
Messed up electrical

We have a 2009 Monaco Diplomat and are having electrical issues. Nothing on the top end of the coach works. No lights, No fans, no vents, no heat/ac roof units, nor is the water heater working. If you press the battery cut off button near the door the lights will come for a couple seconds and go back off. Changed the batteries, not the problem. Anyone else had this issue?

nrupracht is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-19-2012, 06:11 PM   #2
Senior Member
KIX's Avatar

Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,579
Originally Posted by nrupracht View Post
..........If you press the battery cut off button near the door the lights will come for a couple seconds and go back off..............
Sounds like the battery cutoff solenoid. You could jump the two large terminals on the solenoid to see if that's the problem.

'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote
Old 11-19-2012, 06:19 PM   #3
Junior Member
Join Date: Sep 2010
Posts: 10
Thanks! We'll check that out. We thought that possibly was the issue since it's pretty warm. Will let you know how we make out.
nrupracht is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:49 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.