Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-22-2010, 05:35 PM   #15
Member
 
Jbgrams's Avatar
 
Newmar Owners Club
Winnebago Owners Club
Join Date: Dec 2010
Location: Benton, Arkansas
Posts: 42
I would like to thank all those who have responded to my questions, everyone was very helpful. Here is an update: the dealer replaced all the seals on the slide that was leaking, we won't know if this resolved the problem until we head to Florida in January, praying for this issue to be resolved. As for the slide creeping out, the dealer still felt it was our fault for not having the slide locked, which I feel is incorrect. I called Winnebago and spoke with tech named Al, very knowledgeable gentleman, who said I need to have the dealer replace the cylinoid, that the slide should not creep out even if slide not locked. Now a new issue with dead house batteries, so the motorhome going back to dealer Monday, for these items to be addressed and the slide issue to be readdressed. We will post the outcome, thanks again.
__________________

__________________
Jbgrams is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-22-2010, 06:24 PM   #16
Moderator Emeritus
 
RickO's Avatar


 
Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,530
Hang in there

Getting all the bugs worked out of a new coach can really be frustrating but "this too shall pass" You made a good decision to buy a Winnie and they'll stand behind you as you get early failures fixed and get to know all of the systems in the coach yourself so you'll feel more in control when something goes wrong.

Keep us posted.

Rick
__________________

__________________
Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 12-23-2010, 12:56 PM   #17
Junior Member
 
Join Date: Dec 2010
Posts: 1
re slides

I too have an Itasca 2010 Ellipse. Bought it new in Arizona last January and have almost 16,000 miles on it. No problem with the slides whatsoever. Our model, the BD floor plan, has power locks for the slides. The controls are located right beside the in and out controls for the slides, the fold-down panel by the pilot's right knee. There is also a lock on the dash that turns on or off the slide locks. I would think you have the same feature?
__________________
alanez is offline   Reply With Quote
Old 12-23-2010, 04:47 PM   #18
Senior Member
 
MaxTurner1's Avatar
 
Nor'easters Club
Join Date: Dec 2010
Location: Carmel, IN
Posts: 140
Send a message via ICQ to MaxTurner1
Looking for a bit of help. Am new to our 2003 Pace Arrow 37A. When demo-ed all worked well. Got home and rear slide doesn't work. Called, dealer says controll boards are in electrical box in bedroom, mounted on the inside wall. That I will likely find loose wire. It did get bouunced to death, like me, on the Pennsylvania Toll Road. I mean beat to death. Anyone had this and know where to reach?
Mturner1@indy.rr.com
__________________

__________________
MaxTurner1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bosch Brake Problems on Motorhome CarlJudy Workhorse and Chevrolet Chassis Motorhome Forum 21 03-13-2009 01:49 PM
Bounder: Slide Leaks Revisited - Fixed? GerryB54 Fleetwood Products Owner's Forum 22 07-04-2008 04:57 AM
03 Southwind 32VS Slide Problems :( supercub Fleetwood Products Owner's Forum 4 12-27-2005 08:22 PM
Slide Motor Problems supercub Class A Motorhome Discussions 2 10-16-2005 12:20 AM
Elect. 2004 gen slide problems royboy Alpine Coach Owner's Forum 2 08-08-2005 01:50 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.