Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-31-2012, 08:41 PM   #1
Junior Member
Join Date: May 2012
Posts: 1
Newbie problem

As a newbie i attemped to drive off with my 120v power cord plugged in. Now i am not able to reset the bath gfic nor can i get any ac power from my shore line. Can you say dumb move!
2012 fleetwood discovery

topgon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-31-2012, 10:10 PM   #2
Moderator Emeritus
RickO's Avatar

Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,528
Welcome to the forum and don't be too hard on yourself. We all pick up our badge of "honor" at some point. You just got yours early.

I'm sure some of our experts will be along to help soon but I'll bet they'll point you toward looking for wire connections which were pulled loose and are shorting. That might explain the the GFCI issue and why you can't get shore power... although I would almost expect that you might trip the shore power breaker when plugging in if that were the case but....

Best of luck.


Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 06-01-2012, 07:51 PM   #3
Senior Member
Join Date: Nov 2011
Location: Full time RV'er
Posts: 1,238
Your GFIC will not reset if there is no AC present. Check the length of the AC cord to make sure you didn't run over it and tear some insulation off, exposing some fine filaments of wire. Open the 4-square electrical box (or similar) your AC cord goes into (unplugged from shore power of course) and look at all the connections. Usually the input wires are connected to the coaches wiring with wire nuts but sometimes with a terminal strip.
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : http://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:27 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.