Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-04-2014, 09:00 PM   #1
Junior Member
 
Join Date: Jun 2014
Posts: 2
Newmar issue

Have 2000 Mountainaire diesel, Spartan chassis. Starter runs continually, have to disconnect battery post to stop. Replaced new starter solenoid and same thing. Is there another solenoid between starter and ignition switch, need location? Need to find the reason why starter solenoid burns out. Wiring schematic would be helpful. Any help appreciated. Thanks.
__________________

__________________
roamingpete is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-04-2014, 09:46 PM   #2
Senior Member
 
TonyDi's Avatar


 
Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 10,476
Have you checked the ignition switch to make sure it is not hung up in the start position? Disconnect the solenoid, turn key to start and release as you would if starting the engine. Then take a voltmeter and check to see if you still have power at the solenoid, with the ignition in the run position. That's my best guesstimate.
__________________

__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee Hemi, Blue Ox Aventa LX, and Brake Buddy. TST 507 TPMS
TonyDi is offline   Reply With Quote
Old 06-04-2014, 10:00 PM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,804
Welcome to irv2.
Here is a link for reference purposes only ,dash wiring info and here is a thread about starting problem.
If you look in my signature below it will have QT's links for your Newmar information.
When you find the time join us in the Newmar forum.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 06-04-2014, 10:23 PM   #4
Junior Member
 
Join Date: Jun 2014
Posts: 2
Thanks but not my problem. The starter solenoid burns out.....still wondering what would cause that. Appreciate your time Tony.
__________________
roamingpete is offline   Reply With Quote
Old 06-04-2014, 10:49 PM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,804
Two links here find the starter circuit in drawing may steer you to your trouble found in Spartan forum.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 06-04-2014, 11:50 PM   #6
Registered User
 
Join Date: Apr 2013
Location: NV
Posts: 2,227
If someone was down there the wires could be on backwards it will do that if so.
__________________
johnnyreno is offline   Reply With Quote
Old 06-05-2014, 12:16 AM   #7
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,972
There is a contact plate in the starter mounted solenoid , that may be stuck feeding battery voltage straight to the armature.
I'm assuming you have a Denso starter, common on both Cummins and Cat engines, of our vintage, the contact plate, is under the tin cover, held in place by the 3 small bolts on the side of the starter. this cover can be removed and the spring loaded plate removed and examined for burnt contacts.
Power comes from the battery on one side and when the electromagnet pulls the contact plate the power goes to the armature.
With the batteries disconnected, if you put an ohm meter on the studs on each side of the starter mounted solenoid; one cable comes from the battery the other goes into the main starter body to feed power to the brushes and armature. If you get zero ohms then the plate is stuck.
Some where I've seen a video on a similar starter I'll see if I can post a link.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-05-2014, 12:36 AM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,972
Here are images of a Denso starter and the internal solenoid components that give trouble . Still looking for the rebuild video.
Can't find an image that shows the cover plate , may have to take my own.
Cover plate is at the back left of the starter picture, beside the white plastic piece.
Attached Images
  
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 06-06-2014, 12:12 AM   #9
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,972
Google " Denso starter repair video " Many available for other applications of the starter Honda , Chrysler etc. The basic operation is the same , size is the only difference.
Some times the contacts burn on the surface and the starter won't spin over, other times the contacts weld together and the starter wont stop.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
newmar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sword fight between Entegra and Newmar? palehorse89 iRV2.com General Discussion 58 07-02-2014 10:25 PM
Help-Coach step by Lippert issue rccrafters69 Class A Motorhome Discussions 10 06-12-2014 08:10 PM
Future Newmar Owner droptop55 Newmar Owner's Forum 13 02-19-2014 08:53 AM
Intermittent issue engine has no power (7.4 Vortec) C350AMG Workhorse and Chevrolet Chassis Motorhome Forum 8 01-24-2014 09:25 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.