Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-04-2016, 11:01 AM   #1
Junior Member
 
Join Date: May 2016
Posts: 6
No Brake lights

My brake lights do not work in my 95 Safari Sable with a Magnum chassis. All my other lights are working ie running, turn signals, back up, ect. I have replaced my brake pedal switch and checked all my fuses and still no lights. What am I missing?
__________________

__________________
Safari3 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-04-2016, 12:08 PM   #2
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by Safari3 View Post
My brake lights do not work in my 95 Safari Sable with a Magnum chassis. All my other lights are working ie running, turn signals, back up, ect. I have replaced my brake pedal switch and checked all my fuses and still no lights. What am I missing?
Safari3
Have you verified that there is power to the brake light switch, (or that the brake light switch is working)?


'96 Safari Sahara Brake Light Switch

Here's a link to an exact replacement switch: Cole Hersee 90043-07 - Momentary Switch | O'Reilly Auto Parts

Mel
'96 Safari. (Magnum "Blue Streak" chassis)
__________________

__________________
mel s is offline   Reply With Quote
Old 05-04-2016, 12:17 PM   #3
Senior Member
 
bluepill's Avatar
 
Join Date: Jan 2011
Location: Pensacola, FL
Posts: 2,247
1. Do not assume that your bulbs are good.

2. Do not assume that the new switch is good.

Try running a hot jumper directly from the battery to the brake light switch.
__________________
2008 Itasca Meridian 37H & 2015 Flagstaff T12RBST
2011 & 2012 Len & Pat's "One lap of America"
27K miles & 41 states in 13 months - Woo Woo
Yellowstone Lake 6-1-2012
bluepill is online now   Reply With Quote
Old 05-04-2016, 12:25 PM   #4
Junior Member
 
Join Date: May 2016
Posts: 6
Mel thanks for the reply. I replaced that switch yesterday and still no brake lights.
__________________
Safari3 is offline   Reply With Quote
Old 05-04-2016, 12:50 PM   #5
Senior Member
 
Join Date: Dec 2014
Posts: 180
"What am I missing?"

1. One switch as pointed out earlier.
2. A lot of wire.
3. and several connectors.

In 50 years of driving and doing my own work I have never had a bad brake switch... just lucky I guess.

A bad lamp is probably on top of my list.

Second would be a bad connection. Sometimes it is the lamp to socket connection (even with a new lamp installed). Sometimes it has been a connector up stream.

Last would be a broken wire... again just lucky.

An excellent debug tool is a 12V test lamp. Build one yourself with a trailer marker light and some test leads. A high resistant connection upstream will not light your test lamp.

Too difficult for you? Look for corrosion in the lamp socket and for corrosion in the connector attached to the tail light pig tail.
__________________
JoeSR is offline   Reply With Quote
Old 05-04-2016, 01:01 PM   #6
Senior Member
 
FIRE UP's Avatar


 
Join Date: Dec 2009
Location: Out there, somewhere
Posts: 5,282
Quote:
Originally Posted by Safari3 View Post
My brake lights do not work in my 95 Safari Sable with a Magnum chassis. All my other lights are working ie running, turn signals, back up, ect. I have replaced my brake pedal switch and checked all my fuses and still no lights. What am I missing?
Safari3,
At the risk of sounding a bit like an air head here, may I ask, since I'm not familiar with the rear of your coach and, its tail light arrangement, do you have AMBER turn signals or, RED turn signals? If you have Amber ones, then those are a totally different circuit/system than the brake light system so, the bulbs will not be the same.

But, if you have only RED tail lights back there, then most likely your brake light bulb filaments are the same EXACT ones that are used for the turn signals and, as you have stated, your turn signals DO WORK, correct? If so, then you can sort of, rule out bad bulbs. That is unless for some reason, your coaches tail lights are setup and designed to have SEPARATE red brake lights from your turn signals.

Now, it sounds as if you've done some pretty good investigating so far so, much of what I explained above might be moot. But, as another poster stated, you definitely need to insure you have power to the brake switch and, power emanating from it, when the brakes are applied. Obviously if you have a signal being generated from the brake switch but, it's not entering the tail lights, you've got a break in the system some place.
Scott
__________________
2004 ITASCA HORIZON 36GD, 2011 GMC Sierra 1500 4x4 Toad '08 GL 1800 Gold Wing
Retired-29.5 yrs, SDFD, Ham - KI6OND
Me, Karla and the Sophie character, (mini Schnauzer)
FIRE UP is offline   Reply With Quote
Old 05-04-2016, 01:05 PM   #7
Junior Member
 
Join Date: May 2016
Posts: 6
Thanks JoeSR. Pulling my connection apart (under the back bumper) I have been able to determine (with a voltage meter) that my problem is upstream (toward the front of the motorhome). At that connection (under my bumper) I have power to all my other lights but No power to the brake lights. I ran power to the other side of that connection and my lights work so I know my bulbs and light sockets are working.
__________________
Safari3 is offline   Reply With Quote
Old 05-04-2016, 01:11 PM   #8
Junior Member
 
Join Date: May 2016
Posts: 6
Thanks Scott. I will check to see if I have power to my switch. I have spent the last three days tracing that dang white (brake wire) up my coach looking for a split. I was hoping I was just missing a fuse or relay somewhere.
__________________
Safari3 is offline   Reply With Quote
Old 05-04-2016, 05:33 PM   #9
Junior Member
 
Join Date: May 2016
Posts: 6
Thank you all for your suggestions. I have tried them all and still no brake lights. I will be dropping it off at the RV shop and update the post with the culprit. Its only money.
__________________
Safari3 is offline   Reply With Quote
Old 05-05-2016, 02:54 PM   #10
Junior Member
 
Join Date: May 2016
Posts: 6
Ahh Bluepill you were right. I made surre my brake pedal switch was working off the chassis but never confirmed it was getting power after I hooked it up. I ran a wire from my fuse pannel directly to my brake light switch and Brake lights worked. Thanks for everyones posts. This is my first time posting and I can't thank you guys enough. Safe travels.
__________________

__________________
Safari3 is offline   Reply With Quote
Reply

Tags
brake, brake lights, light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No parking lights clearance lights or marker lights Janwhite31 Class A Motorhome Discussions 4 06-25-2015 09:10 AM
Marker lights,clearance lights and brake lights Ahall Entegra Owner's Forum 1 04-18-2014 06:39 AM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Motorhomes Owners Forum 3 02-26-2014 08:02 AM
Motor home brake lights work but trailer brake lights don't Gerdean Toads and Motorhome Related Towing 9 09-11-2013 11:04 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.