Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2016, 12:44 PM   #1
Junior Member
 
Join Date: Oct 2013
Posts: 10
No gauges working

I have a 2002 Winnebago Journey and all of my gauges stopped working. The motorhome runs but no gauges or message center lights. Anybody else had this happen? If so, was it a Vdc problem or the ignition switch or how did you fix it?
__________________

__________________
Mikesmowing is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-09-2016, 12:55 PM   #2
Registered User
 
Join Date: Sep 2014
Posts: 2,312
This seems related;

Lost Dash Gauges
__________________

__________________
1998 Tioga Class C
400 amp/hrs solar, Trimetric
Retire 2020 GLW
okcnewbie is offline   Reply With Quote
Old 05-09-2016, 10:21 PM   #3
Senior Member
 
Join Date: Nov 2003
Location: Richmond Hill, GA USA
Posts: 671
The other thread posted above has some good ideas, but it is not the system in your 2002 coach.

Here is the troubleshooting info for your system:
http://www.discoveryowners.com/VDCTR...OTINGGUIDE.pdf

I would try to find the connector that connects to the message center, and reseat that one. The 2 data lines and + and - wires from the VDC go to the message center. From the message center, a spider harness drives the individual instruments.

You can also get some free advice from the Freightliner help Desk (free service). Have your VIN number available when you call. 1 800 FTL HELP

Fred
__________________
Fred & Vicki
St. Augustine, Fl.
Fred Cooper is offline   Reply With Quote
Reply

Tags
gauges



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauges not working properly skidboot28 Monaco Owner's Forum 9 07-22-2011 10:12 PM
Gauges not working! Rvfeller MH-General Discussions & Problems 4 07-11-2010 06:01 AM
boost and EGT gauges not working PlayItForwrd Freightliner Motorhome Chassis Forum 2 04-05-2010 08:56 AM
Banks gauges not working PlayItForwrd MH-General Discussions & Problems 2 03-15-2010 11:53 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 05:22 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.