Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-02-2015, 09:40 AM   #1
Junior Member
Join Date: Feb 2012
Posts: 4
No Power to Accessories

When we turn the ignition on, we have no power to accessories -- dash fans / ac, radio, backup camera, stair step, etc. Any idea what could cause this?

lsauer1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-02-2015, 01:20 PM   #2
Senior Member
tikitom's Avatar
Monaco Owners Club
Join Date: Apr 2012
Posts: 240
That happened to our HR once. Our house batteries were dead.

Tom and Barbara in Delaware, USAF Retired Aircraft Crew Chief
2001 Monaco Dynasty Regent DSO FD - 40 ft DP with Tag Axle - Towing a 2003 Jeep Wrangler

tikitom is offline   Reply With Quote
Old 07-02-2015, 01:26 PM   #3
Senior Member
OLYLEN's Avatar
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 1,524
Check chassis battery for charge or battery cut off switch. Corroded terminals. If you use the emergency start switch do you get power?

2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 07-10-2015, 11:57 AM   #4
Senior Member
NMRVer's Avatar
Thor Owners Club
Ford Super Duty Owner
Join Date: Jul 2014
Location: Alamogordo, NM
Posts: 274
Mine don't work unless I throw the disconnect/use switch to use. Batteries...
Ford RV V10 5 star Tow tune
Front/Read Roadmaster 1 3/4" anti-sway bars. Roadmaster steering stabilizer
2009 Acme Tow dolly w/ 2014 Avalon Hybrid Limited
NMRVer is offline   Reply With Quote
Old 07-10-2015, 06:58 PM   #5
Senior Member
Ray,IN's Avatar
Join Date: Aug 2001
Location: North America somewhere
Posts: 12,303
Originally Posted by NMRVer View Post
Mine don't work unless I throw the disconnect/use switch to use. Batteries...
I'll bet you a doughnut you named their problem.
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert theConstitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 07-10-2015, 09:00 PM   #6
Senior Member
mvpmich's Avatar
Freightliner Owners Club
Join Date: Jan 2012
Location: SE Michigan & Central Florida
Posts: 198
No Power to Accessories

On a more technical note, try checking to see if there is power to any of the fuses to the accessories you mentioned. If none, check the ignition solenoid. If it has shorted out or failed, it won't provide power to the accessories when the ignition is on. Happened to me after a number of strange electrical occurrences. It shorted because one of the lugs was loose.

2012 Sportscoach Cross Country 385 DS Freightliner XCR w/ Cummins ISB 6.7L 340 hp
2009 Saturn Vue, Blue Ox Alpha, RVi Brake 2
mvpmich is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No power to chassis dgrover Ford Motorhome Chassis Forum 3 04-20-2015 04:31 PM
Partial power loss on Power Distribution panel MikeandBecky Class A Motorhome Discussions 16 02-17-2015 06:01 PM
Onan 7500 power transfer switch problem? BigDBright RV Systems & Appliances 11 08-14-2014 09:59 AM
troubleshooting no power to receptacle gemini5362 Class A Motorhome Discussions 12 04-19-2014 08:35 AM
Banks Power Ultimate RV Power System - any experience? Dusterella Toads and Motorhome Related Towing 5 04-11-2014 01:38 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.