Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-16-2014, 08:57 PM   #1
Junior Member
 
Join Date: Apr 2013
Location: Nanoose Bay, BC
Posts: 18
No power to anything without engine running

I got a problem, just took the RV out of shop to go on a trip, all batteries are good and started fine, however I can get nothing to run off battery or shore power ? Everything works with main engine running but when it shuts off everything else does too including generator. Its a 2005 Itasca Merdiaina 39' cat 350. All circut breakers are in (nothng popped out), main breakers are all on, inverter/converter clicks when plugged into shore 110 outlet and can hear it slightly humming. Tested all batteries with load test as well as hydrometer. Im suspicious of the AUX battery switch on dash as its acting like this swith is in the off position but dont know if that switch kills power to interior stuff when main engine running as well ?? Anyone with ideas please let me know.
__________________

__________________
deepfish is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-16-2014, 09:57 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
If the , salesman switch on my coach is flipped or the relay defective , all interior lights would operate with the engine running. The BIRD charging system would activate and by trying to charge the coach batteries , power up the interior.

Salesman switch is a different one than the aux start. Mine is inside a cabinet above the stairs to the entry door.

EDIT: Salesman switch, could ( should ) be labeled battery disconnect ; and only works on the coach battery. Shop worker may have hit the switch to keep your batteries from being drawn down, while waiting for you to pick the rig up.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-17-2014, 07:04 AM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,753
x2 with Skip.
If you have a Bird System this is how it functions.
Your battery cut off switch, which you may operate when not using coach to conserve battery charge and a salesman switch need to be on when coach is in use.
This link may help also.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine running to warm? oildriller83 Class A Motorhome Discussions 2 05-23-2014 08:23 AM
Banks Power Ultimate RV Power System - any experience? Dusterella Toads and Motorhome Related Towing 5 04-11-2014 02:38 PM
8.1 Chev Engine idles NO POWER "will not rev" UNTIL anderson2624 Tiffin Motorhomes Owners Forum 1 04-06-2014 01:01 AM
Generator running but no power to outlet plugs HethaBeth MH-General Discussions & Problems 9 03-31-2014 01:17 AM
Starting engine while on shore power Mitchone iRV2.com General Discussion 17 01-09-2014 07:37 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.