Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 10-18-2015, 12:41 PM   #1
Junior Member
Join Date: Oct 2015
Posts: 2
Oasis Hydronics System Problem

I have a Newmar Ventana (2014) purchased new. I have not used the hydronics unit much until this week. When I cut it own and turn the thermostat to furnace I get a zone fault. Further diagnosis from the panel shows a problem with Heat Loop 1. Any suggestions on fixing it? It will be cold tonight.

Thanks in advance.


Lynn Daniel is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-18-2015, 06:51 PM   #2
Senior Member
Country Coach Owners Club
Join Date: Mar 2014
Posts: 100
I have an older rv with a webasto diesel boiler. I just had to work on it and first thing I do is go to the books and it states " run unit for 20 minutes every month summer and winter" of course I have own this bus going on 2yrs and never started it once. Now after pulling it apart and repairing it I now am pretty fulmilure with it, mine has a separate from the burner circulation pump, you may want to see if yours is running. If not check to see if it's getting voltage

Hondalee is offline   Reply With Quote
Old 10-18-2015, 06:57 PM   #3
Senior Member
Country Coach Owners Club
Join Date: Mar 2014
Posts: 100
Mine was not firing so I replaced nozzle and adjusted fuel pressure, cleaned and adjusted igniter probes. It smoked like my old 65 Rambler for about 10 min till it burnt off built up diesel.
Hondalee is offline   Reply With Quote
Old 10-19-2015, 05:53 AM   #4
Senior Member
Stealth01's Avatar

Newmar Owners Club
Join Date: Jun 2013
Location: MidWest
Posts: 629
Need more information... Have you looked at the unit itself for fault lights? Check the zone board for red lights, red light normally indicates blown fuse. Fuse is 10 amp. If fuse is good, check for voltage to the circulation pump. If good voltage change the circulation pump (in a pinch you can turn on the "By Pass" switch which will circulate fluid throughout the system.) If the loop pump is running, but you're not getting warm air at the vent, "smartly" tap the pump check vale to un-stick the valve.
Ken & Anita
2011 Newmar Essex, 45'- 4522, Cummins 500 ISM, 2013 CRV, RVI2 Brake with TPMS
Stealth01 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear View Safety Wireless Camera System scbwr Travel Trailer Discussion 8 09-27-2015 03:12 PM
Rear View Safety Wireless Camera System scbwr Technology: Internet, TV, Satellite, Cell Phones, etc. 2 04-30-2015 03:25 PM
Winnebago Announces $7 Million State-of-the-Art E-Coat System DriVer RV Industry Press 0 03-25-2015 07:58 PM
Winterizing the Oasis System Kend51 Newmar Owner's Forum 4 03-11-2015 05:26 PM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 06:18 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.