Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 01-06-2013, 04:41 PM   #1
Senior Member
crah's Avatar
Join Date: Sep 2011
Location: Las Vegas
Posts: 682
Odd transfer switch behavior

I've recently noticed an odd behavior with my transfer switch. To give some history, last year I replaces the 50 amp iota with a 50 amp power max transfer switch. I'm noticing two odd behaviors. 1, I notice that the built in time delay for the generator does not work when I'm hooked into shore power and then try to start the genset. As soon as I start the genset the switchover happens instaneously with no delay. If I'm not hooked to shore power the genset will delay about 30 seconds before it energizes which is normal. I can't figure out why it would do that. 2, when I start the genset without shore power but have the thermostat setting on the on position, the genset will not energize. The display on my Intellitec load meter flashes each time the genset tries to switch over. As soon as I shut the t stat switch to off the genset will switch over.

I start my genset always with no original load. I can't figure out why the AC t stay in the on position would cause this problem as there is usually a time delay on the AC as well. I'm wondering I this is related to my ems somehow.
Craig 2003 Holiday Rambler Scepter 36PST
RR8S 350 Cummins ISC with Banks
2011 Buick Enclave Towed with Readybrute
crah is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:38 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.