Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2014, 10:26 PM   #1
Junior Member
 
Join Date: Dec 2013
Posts: 3
Onan 6.5 lp gen set

Has anyone had a problem with generator not putting out power? worked fine until auto transfer switch went bad. Help please!!!
__________________

__________________
blkvectra is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-21-2014, 01:09 AM   #2
Senior Member
 
gruelens's Avatar
 
Join Date: Jul 2012
Posts: 1,286
You will need to give members more info so we can help you. Your transfer switch went bad........ was it replaced?
Do you have any power to the breakers built into the generator?
Power to the transfer switch?
Does transfer switch deliver power to coach when on shore power?
__________________

__________________
George R. - Fulltiming since January '03
2007 Newmar Mountain Aire 3991
2012 Chevy Malibu LT1
gruelens is offline   Reply With Quote
Old 03-21-2014, 01:16 AM   #3
Senior Member
 
Papa_Jim's Avatar
 
Outdoors RV Owners Club
Join Date: Oct 2009
Location: Manitoba,Canada
Posts: 2,638
Did you check the main breakers on the generator? Also, there's a fuse in the panel with the main breakers on the generator. Also, the main control board in the generator can get damaged. There's better sources than Cummins for that board. Don't have that info with me right now. I'll get it for you if you need it.

Jim
__________________
Jim & Kate
2016 Creekside 23RKS
2014 Ram 1500 4X4 Eco Diesel
Canada, eh?
Papa_Jim is offline   Reply With Quote
Old 03-22-2014, 05:26 PM   #4
Junior Member
 
Join Date: Dec 2013
Posts: 3
Quote:
Originally Posted by blkvectra View Post
Has anyone had a problem with generator not putting out power? worked fine until auto transfer switch went bad. Help please!!!
We removed auto transfer switch and put a 50 amp plug in it has shore power. The generator starts and run good just no output power detected. Breakers are ok.
__________________
blkvectra is offline   Reply With Quote
Old 03-22-2014, 05:35 PM   #5
Senior Member
 
Melmoses's Avatar
 
Tiffin Owners Club
Join Date: Aug 2010
Location: Montgomery, AL
Posts: 1,196
It sounds like you completely removed the transfer switch and if that is what you did that is your problem. The transfer switch toggles the power between the generator and 50 amp service. Without a transfer switch plugged directly into 50 amp there is no connection for power from the generator.
__________________
Mel (Melanie) and Harry
2009 Tiffin Phaeton 40QTH
2014 Jeep Wrangler Sport
Melmoses is offline   Reply With Quote
Old 04-16-2014, 09:18 PM   #6
Junior Member
 
Join Date: Dec 2013
Posts: 3
we put a plug in for the generator or coach to plug into generator
__________________
blkvectra is offline   Reply With Quote
Old 04-18-2014, 12:27 AM   #7
Senior Member
 
SuperGewl's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Aug 2004
Location: Oregon
Posts: 1,782
OK are you saying that you have to actually plug the generator into an outlet for it to work and this is the same outlet as the Shore power? If so this is not a good idea. Replace the Transfer Switch and ensure you reconnect it all correctly. In most cases there is some circuitry that senses the Generator running coming from this Transfer Switch that is needed in order for it to feed the coach.
__________________

__________________
Retired Navy Submariner
2014 Itasca Sunstar 35F; 5 Star tuned; 2014 Jeep Cherokee TrailHawk
SuperGewl is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen set power slumping below 110v RufussSewell Class A Motorhome Discussions 56 03-27-2014 12:12 PM
Onan 4KW Gen set not starting jazzerjump Winnebago Industries Owner's Forum 16 03-12-2014 10:48 PM
Onan gen blowing fuel pump - auto choke fuse Rockyroad MH-General Discussions & Problems 3 02-22-2014 06:45 AM
I have a Onan 7.5 qd gen set issue johnboy2 RV Systems & Appliances 1 02-16-2014 08:12 PM
Onan Gen and Cummins ISL Oil Filter Number Scepter1 Class A Motorhome Discussions 3 01-20-2014 05:18 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.