Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-30-2016, 10:47 AM   #1
Junior Member
 
Join Date: May 2011
Posts: 7
Onan 7000kw 30 sec run then stop

Purchased a used 1992 Holiday Rambler Imperial with a 7000kw Onan Marquis Generator. Had 900 hrs on it & ran well according to former owner. However after driving it home a few days later tried to start it & would not start. So filled the 75gal gas tank, filled the oil on the generator to full with HD 30 and been running like a champ for 3 weeks. 1hr to 6-8hrs/day with quick strong start up & smooth strong run every time. Then about a week ago it would start strong then 30 seconds later it would quit. Did multiple strong starts but after 30 seconds it would shut down. So began testing the 8 visible circuits on the board where power is sent to refrigerator, microwave, lights but detected no shorts in those circuits. Has 2 circuit breakers and when 1 of those circuit breakers is turned off the generator continues to run strong. Otherwise - start up, run 30 seconds then complete shutdown.
__________________

__________________
mysbabylon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-30-2016, 11:00 AM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,232


When it shuts down, is it an immediate cutting of power or does the engine strain under load? If it sounds starved for gas, it could be the filter or the fuel pump, a special, low pressure pump Onan uses. I don't know if your generator has it, but newer Onan generators set a code that can be read by counting the blinking light at the generator panel.

How does power get switched into the RV? Do you have an ATS (automatic transfer switch) or do you have to physically plug it in? If a plug, you could try starting with it unplugged to see if it's an issue with the RV wiring or the generator. When running with the one circuit breaker off, do half the outlets work in the RV?

You need to search and download the appropriate manual for your generator. I don't know if this one covers your model or not.

http://www.americanrvcompany.com/ass...atormanual.pdf
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 03-30-2016, 12:01 PM   #3
Junior Member
 
Join Date: May 2011
Posts: 7
Need correct URL. ass…????
__________________
mysbabylon is offline   Reply With Quote
Old 03-30-2016, 12:04 PM   #4
Junior Member
 
Join Date: May 2011
Posts: 7
No blinking lights on this unit from all I can tell to determine problem via code.
__________________
mysbabylon is offline   Reply With Quote
Old 03-30-2016, 12:06 PM   #5
Junior Member
 
Join Date: May 2011
Posts: 7
Immediate cutting of power, no straining under load.
__________________
mysbabylon is offline   Reply With Quote
Old 03-30-2016, 12:07 PM   #6
Junior Member
 
Join Date: Aug 2010
Location: SE Ks
Posts: 6
had that problem with my '98 brave and was fuel pump at fault.
__________________
Jim in SE Ks is offline   Reply With Quote
Old 03-30-2016, 12:11 PM   #7
Junior Member
 
Join Date: May 2011
Posts: 7
Power switched to RV dunno? One circuit breaker is 30amp, other is 20amp. Turned off 30amp Onan kept running. What circuits were being fed I could not determine. We did test all 8 circuits & found no shorts in ones we tested like to frig or lights or power converter.
__________________
mysbabylon is offline   Reply With Quote
Old 03-30-2016, 12:14 PM   #8
Senior Member
 
Join Date: Jul 2014
Posts: 9,848
Check the oil ?

If low it will shut down.
__________________
twinboat is online now   Reply With Quote
Old 03-30-2016, 12:15 PM   #9
Senior Member
 
homecan1's Avatar
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2013
Location: Southern California
Posts: 195
I would suggest that it is the fuel pump. Cheap and easy repair. Make sure you get the correct part number from the manual not just the number of the pump that is on it. I did that once and found out that a PO had installed the wrong pump. Get a new filter as well. With load, the generator has to increase RPM and the old or incorrect fuel pump can't keep up. If that does not solve, there is also an oil pressure/level sensor and a high temp sensor that can go bad but they are much less common.
__________________
Palm Springs, CA - 2005 National Tropi Cal 370LX on a Freightliner, Cat 350 power. Towing a Rinker R1 - Lake Havasu Bound!!
homecan1 is offline   Reply With Quote
Old 03-30-2016, 12:28 PM   #10
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,232
Quote:
Originally Posted by mysbabylon View Post
Need correct URL. ass…????
(http://www.)americanrvcompany.com/assets/images/hgjaabcOperatormanual.pdf

That was 'assets.'
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 03-30-2016, 12:42 PM   #11
Junior Member
 
Join Date: May 2011
Posts: 7
If anything its too much oil. When it first did the shutdown thing - I pulled out HD 30 oil & added in dark so now oil is overfilled.
__________________
mysbabylon is offline   Reply With Quote
Old 03-30-2016, 12:47 PM   #12
Senior Member
 
Join Date: Jan 2016
Posts: 492
Mine's a 5500, but it did the same thing. You get the pump and filter for around 50 bucks on Amazon. I replaced them last week. Check those fuel lines also. They get brittle down there. Hope you have small hands!
__________________
Lovey & Thurston - Cali Foothills
2001 HR Vacationer (SS Minnow) - Gasser!
Obviously A Lowly and Inferior MH
B Dubya is offline   Reply With Quote
Old 03-30-2016, 12:49 PM   #13
Senior Member
 
Join Date: Jan 2016
Posts: 492
Found this thread.


What's wrong with my Genny? (Kind of long)
__________________
Lovey & Thurston - Cali Foothills
2001 HR Vacationer (SS Minnow) - Gasser!
Obviously A Lowly and Inferior MH
B Dubya is offline   Reply With Quote
Old 03-30-2016, 12:52 PM   #14
Junior Member
 
Join Date: May 2011
Posts: 7
So far 7000kw generator is a long way from overload. Mostly some interior lights, refrigerator, microwave but no serious loading since I have been using it. No electric 1500kw heaters no 2500 kw air conditioners as far as I can determine very light electrical loads for past 3 weeks. Don't even have running water yet with accompanying water pump. Never use showers etc. So going from running 3 to 7 hrs/day with 7000kw generator and very light elec loads to running 30 seconds and quiting, then being able to start it up again immediately than run strong or typical as has for 3 weeks under minimal loading than in 30 seconds it stops abruptly seems strange.
__________________

__________________
mysbabylon is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 7000kw QD Generator michguy Class A Motorhome Discussions 2 08-16-2015 09:34 AM
Gen Set won't run but about 1 sec nails Winnebago Industries Owner's Forum 7 09-12-2013 07:26 PM
Jacks down then slides or slides then jacks down? Yolo72 Entegra Owner's Forum 10 01-29-2013 09:13 PM
A/C blows cold then hot then cold...... 1kingtut Monaco Owner's Forum 5 08-20-2012 10:09 PM
Hot water, then cold, then hot, then cold VACMAN Newmar Owner's Forum 4 05-26-2009 10:48 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.