Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-10-2011, 10:34 AM   #1
Junior Member
 
Hillbillyjoe's Avatar
 
Join Date: Jul 2011
Location: Bowie, texas
Posts: 10
Onan 7500 diesel Gen problem?

I,ve been having some trouble with my Gen set surging. I Also noticed my dc amps on my inverter remote panel was jumping from 50 up to 150 dc amps. I found one of the 3 coach batts was bad. Changed all 3 and it settled down. Now I still have this surge so I checked the outlet power and I am getting 91 to 109 vac swing. I turned off all main breakers to isolate any load on the Gen set. I opened to termination panel on the Gen and started it backup ,I measured voltage at the Gen and I,m still getting same low voltage reading. Could I have a bad regulator? Or something. I did plug house power in and checked voltage, power was good at 122vac. I did this to make sure my meter was good. Any one had this problem? Any advice is greatly appreciated

J
__________________

__________________
Hillbillyjoe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-10-2011, 11:13 AM   #2
Senior Member
 
RJay's Avatar
 
Newmar Owners Club
Join Date: Jan 2010
Posts: 4,589
It sounds like you may have a controller problem. What is the fault code? If it's 13 it's the controller.
__________________

__________________
2007 Newmar DSDP 4023
Discovery is seeing what everyone else has seen and thinking what no one else has thought.
If you want to see what man made go East; if you want to see what God made go West.
RJay is offline   Reply With Quote
Old 07-10-2011, 11:24 AM   #3
Junior Member
 
Hillbillyjoe's Avatar
 
Join Date: Jul 2011
Location: Bowie, texas
Posts: 10
I had no fault code. Not even the secondary code. Now it did surge enough when I had the ac running to shut it,s self down. But no codes came up. I was running ac until I realized the voltage was low. Stopped that so I did,nt damage ac unit. I did have the Gen set in for service in may. Took it to cummins in fort worth,tx. I had lost the temp sensor on the engine which was causing it shut down on temp. Code 33. It turned out to be radiator. This surge problem started after I got it back. Go figure. They did say they load tested it after repair. I was told I was,nt running Gen correctly each month. I wasn't loading it up and running it for 2 hrs. Do you think I,m measuring voltage correctly?
__________________
Hillbillyjoe is offline   Reply With Quote
Old 07-11-2011, 03:45 PM   #4
Senior Member
 
tom77hmstd's Avatar
 
Join Date: Jan 2011
Location: homestead fl.
Posts: 280
I know this sounds pretty basic but it sounds like a possible fuel problem,filter, pinched supply or return line. Or is the level in the mh tank close to the 1/4 tank level where the supply pick up stops? I think it sounds like a mech problem since no codes were set.If the unit was removed to fix the rad I would check the lines first.For what it is worth.
__________________
tom77hmstd is offline   Reply With Quote
Old 07-11-2011, 04:31 PM   #5
Senior Member
 
Join Date: Apr 2003
Location: Oakton, Va
Posts: 1,149
If the RPMs of the engine are surging then it is probably a problem with the diesel engine.
__________________
Jim Walker
N Virginia
2014 Palazzo 33.2
Cummins 6.7 ISB, Allison 2100 6 Speed
J Walker is offline   Reply With Quote
Old 07-12-2011, 05:51 AM   #6
Junior Member
 
Hillbillyjoe's Avatar
 
Join Date: Jul 2011
Location: Bowie, texas
Posts: 10
Thank you, I did replace the fuel filter. Lines looked ok from what I could see. Main fuel was at half a tank but still could not get a steady output voltage. 90vac to 111vac.
__________________
Hillbillyjoe is offline   Reply With Quote
Old 07-12-2011, 03:52 PM   #7
Senior Member
 
tom77hmstd's Avatar
 
Join Date: Jan 2011
Location: homestead fl.
Posts: 280
Still sounds like a engine problem low rpm means low voltage could be fuel pump or injector or lots of other stuff. These desk diagnose problems are TUFF. Without hearing the engine or seeing it it is almost impossible to help. All you can do from a distance is recommend throwing parts and money at it.
__________________
tom77hmstd is offline   Reply With Quote
Old 07-12-2011, 04:45 PM   #8
Junior Member
 
Hillbillyjoe's Avatar
 
Join Date: Jul 2011
Location: Bowie, texas
Posts: 10
Quote:
Originally Posted by tom77hmstd
Still sounds like a engine problem low rpm means low voltage could be fuel pump or injector or lots of other stuff. These desk diagnose problems are TUFF. Without hearing the engine or seeing it it is almost impossible to help. All you can do from a distance is recommend throwing parts and money at it.
Your right, I,ve got an appointment with cummins southerns plains in Arlington Texas.I spoke with their tech support. Could be inverter, .loose wire, stator, $$$$. .thank,s for all the input on this issue.
J
__________________

__________________
Hillbillyjoe is offline   Reply With Quote
Reply

Tags
onan, diesel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan diesel generator problems TD257 MH-General Discussions & Problems 3 05-29-2011 08:10 AM
Mystery start of Onan 8000 Diesel Gen pvm171 RV Systems & Appliances 5 01-23-2011 11:14 AM
Onan diesel generator engine smokes BAD.. Swannee MH-General Discussions & Problems 1 09-03-2010 02:05 PM
xantrex auto gen start problem Techie RV Systems & Appliances 3 09-15-2008 07:54 AM
Onan Quiet Diesel Problem Need Help bdpreece MH-General Discussions & Problems 3 01-09-2008 07:07 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.