Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 01-24-2012, 03:19 PM   #1
Junior Member
Join Date: Jul 2009
Location: NC
Posts: 5
Onan 7500 generator won't start.

I replaced my house 6 volt house batteries and now I can't get the generator to make a sound. It started slowly before I replaced the batteries but at least it did start. This is in my 2004 Coachman Cross Country. I 've put a meter on all of the fuses I can find and they are all good. Does anyone have any ideas? It is diesel.

mrwedeliver is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-24-2012, 03:38 PM   #2
Senior Member
Rook's Avatar
National RV Owners Club
Solo Rvers Club
Freightliner Owners Club
Join Date: Mar 2011
Location: FT for 6 years, NW in the summer, S in winter.
Posts: 992
With a voltmeter, make sure you have 12V at the starter solenoid right at the Generator. If you do, then press the start button and see if the solenoid "clicks"....starter should run. Rook

When you get a chance to dance, or sit this one out......I hope you DANCE!

98 National Tradewinds 7370, powered by a 3126B 300HP CAT Turbo, Freightliner XC chassis
Rook is online now   Reply With Quote
Old 01-24-2012, 03:41 PM   #3
Senior Member
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 3,964
Did you put the batteries in series? Minus to plus. Get a flashlight and look carefully to see if you left off the generator lead.
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 01-24-2012, 03:57 PM   #4
Junior Member
Join Date: Jul 2009
Location: NC
Posts: 5
Checked out the generator leads and they are connected.
mrwedeliver is offline   Reply With Quote
Old 01-25-2012, 04:48 PM   #5
Senior Member
Freightliner Owners Club
Join Date: Sep 2011
Posts: 205
Since you were having problems BEFORE you replaced the batteries, you may have a failure on one of the cable ends, running from batts to gen. Remove, clean, check, wiggle, carefully. If they are crimped on, and covered with shrink sleeves, the bad connection may not be readily visible. And, they may check Ok with a meter, but, when you hit them with the demand of a starter draw, the bad, aka, high resistance connection will not allow sufficient current to pass, and start the machine....
Back to a 5'er after 4 yrs fulltime.
Pulling with a '14 2500 ram, 6.4 Hemi.
Montana High Country 31RE
free-to-roam is offline   Reply With Quote
Old 01-26-2012, 01:08 PM   #6
Junior Member
Join Date: Jul 2009
Location: NC
Posts: 5
Thanks, that suggestion will be my next step. If it works, I'll be back in touch!

mrwedeliver is offline   Reply With Quote

generator, onan

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan generator turns but won't start - again baloo Class A Motorhome Discussions 21 01-28-2012 04:36 AM
Onan 7500 randco RV Systems & Appliances 3 05-26-2011 04:47 AM
Onan 7500 code 24 hdeddie Class A Motorhome Discussions 1 12-20-2010 03:30 PM
Onan Kubota Start Problem noladiver Monaco Owner's Forum 12 10-31-2009 07:40 AM
Onan LP Generator hard to start Darryl RV Systems & Appliances 2 10-27-2009 09:26 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:20 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.