Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-25-2015, 07:32 PM   #1
Junior Member
 
Join Date: Oct 2015
Posts: 1
Onan Emerald III Genset Not starting

Hello all, I have a 6500 Onan Emerald 3 Genset that is giving me fits. Right now, when I press start all I get is a click (or sometimes multiple clicks), but it does not turn over. The batteries are charged, and I get a good reading with the voltmeter when I check the positive and negative on the generator. Any suggestions on where to go next?

Thanks,

Andy
__________________

__________________
MotoRV is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-25-2015, 07:47 PM   #2
Senior Member
 
CJ7365's Avatar
 
Tiffin Owners Club
Join Date: Mar 2015
Location: Southern NM
Posts: 1,524
I would check the terminals on the battery for looseness or corosion, also check the voltage at the battery while someone is trying to start it and see what the voltage is.


not familiar with your genset, also a bad starter solenoid would have these systems as well
__________________

__________________
2005 Tiffin Allegro Bay 37DB
W22 Workhorse Chassis 8.1 Flat Towing a 82 Jeep CJ7
CJ7365 is online now   Reply With Quote
Old 10-25-2015, 08:16 PM   #3
Member
 
Join Date: Jun 2015
Posts: 38
Is your generator interlocked with the motorhome ignition?
I also have an emerald III and the ignition has to be keyed "on".
__________________
Ryan7361 is offline   Reply With Quote
Old 10-25-2015, 09:46 PM   #4
Senior Member
 
Johndale's Avatar


 
Winnebago Owners Club
Join Date: Sep 2013
Location: Ft Worth texas
Posts: 963
Put your meter on the positive battery post on the gen. And neg on frame then hit the start switch and look at the voltage drop under load. That is the only way to do a good battery check under load.


Sent from my iPhone using iRV2 - RV Forum
__________________
2003 Sightseer 33L
Ford F53
Johndale is offline   Reply With Quote
Old 10-26-2015, 03:12 AM   #5
Senior Member
 
Ranger Smith's Avatar
 
Join Date: Jul 2012
Location: Where the Rig is Parked
Posts: 933
Quote:
Originally Posted by Johndale View Post
Put your meter on the positive battery post on the gen. And neg on frame then hit the start switch and look at the voltage drop under load. That is the only way to do a good battery check under load.


Sent from my iPhone using iRV2 - RV Forum
Second that . . . If voltage is good then starter itself might be bad but I'll bet you have a bad connection or a bad battery. Even though you might have 12 volts there it can't handle the current.
__________________
Steve and Joy
2016 Tiffin Allegro 36LA
Where We Are Now
Ranger Smith is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Emerald Plus Johntraveler iRV2.com General Discussion 4 09-18-2015 08:21 PM
Onan Emerald 111, sine wave? theartist RV Systems & Appliances 5 08-05-2015 01:41 AM
Onan Genset power production issue Globetrotter Monaco Owner's Forum 4 05-23-2015 11:20 AM
Onan Genset NHE not starting... 88Shasta RV Systems & Appliances 6 10-04-2013 04:18 PM
Alternator on an Onan genset red raby RV Systems & Appliances 3 07-27-2013 07:01 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.