RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-21-2019, 09:45 AM   #1
Member
 
Join Date: Sep 2019
Posts: 49
ONAN generator

I am having issues with my on board generator. It is an ONAN 4k microtite model E. I have replaced the carb, fuel pump and delivery is working, fuse and breaker is good. I can try and start and it seems to want to start, but shuts off as soon as i let go of start button. I have tried to disconnect the wire for the oil sensor, no luck. I have tried oil level filled on low side and high, no luck. It is a new to me motorhome and this is one of the main things that i cant figure out. Since it is in the motorhome it makes it slightly tougher to work on, so detailed instructions help a bunch. Any help would be amazing.
__________________

__________________
new to me 1997 Pace Arrow 30
always a work in progress
Joestein is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-21-2019, 09:52 AM   #2
Senior Member
 
jenandjon's Avatar
 
Join Date: Aug 2013
Posts: 833
Try this forum. They helped me out with my Onan. There are some real experts on there.

https://www.smokstak.com/
__________________

__________________
93 Jayco RK 325, 03 freightliner Columbia HDT 435 hp 60 series Detroit, 10 speed, 3:55 gears with full locker. 260 inch wheel base, 07 Chevy classic crew cab long box LBZ Duramax. I am a Father, Farmer, and A Trucker.
jenandjon is offline   Reply With Quote
Old 10-21-2019, 09:54 AM   #3
Senior Member
 
Join Date: Sep 2014
Posts: 3,038
This is one of the most common failures. Often the gen is not creating power.

Here is one of many troubleshooting guides. Also, the manual should be at the link;

http://www.twinslan.net/~n0nas/manuals/onan/
Attached Files
File Type: pdf onan-rv-troubleshooing-guide[1].pdf (2.58 MB, 4 views)
__________________
1996 Tioga Class C
400 amp/hrs solar, Trimetric

Retire 2020 GLW
okcnewbie is offline   Reply With Quote
Old 10-21-2019, 09:54 AM   #4
Senior Member
 
Bill 3rd's Avatar
 
Join Date: Mar 2017
Posts: 141
Spark plug?
Fuel may be at or below 1/4 full.
No A/C output
Bill 3rd is offline   Reply With Quote
Old 10-21-2019, 09:57 AM   #5
Senior Member
 
Join Date: Sep 2014
Posts: 3,038
Here is a little t/s chart out of my 4Ky manual.
Attached Files
File Type: pdf Start_swith.pdf (65.4 KB, 3 views)
__________________
1996 Tioga Class C
400 amp/hrs solar, Trimetric

Retire 2020 GLW
okcnewbie is offline   Reply With Quote
Old 10-21-2019, 09:58 AM   #6
Member
 
Join Date: Sep 2019
Posts: 49
Fuel level is good. Rv is near full on gas. Spark plug is good. Ive tried to do most of the easy stuff. Also since i just got it i went through all that from the start. I have seen plenty of these trouble shooting guides but cant ever figure out exactly which terminals to test for most of them.
__________________
new to me 1997 Pace Arrow 30
always a work in progress
Joestein is offline   Reply With Quote
Old 10-21-2019, 10:05 AM   #7
Member
 
Join Date: Sep 2019
Posts: 49
That trouble shooting chart is where i get confused. I for some reason cant figure out what terminal block is what and where to test what.
__________________
new to me 1997 Pace Arrow 30
always a work in progress
Joestein is offline   Reply With Quote
Old 10-21-2019, 10:10 AM   #8
Senior Member
 
Join Date: Sep 2014
Posts: 3,038
Quote:
Originally Posted by Joestein View Post
That trouble shooting chart is where i get confused. I for some reason cant figure out what terminal block is what and where to test what.
Then you need to download the service manual and read. Sorry, but all the info is there if you research.

I agree if you get a to a really difficult problem than the guys at Smokstak are awesome.
__________________
1996 Tioga Class C
400 amp/hrs solar, Trimetric

Retire 2020 GLW
okcnewbie is offline   Reply With Quote
Old 10-21-2019, 11:28 AM   #9
Senior Member
 
Join Date: May 2017
Posts: 141
Mine did a similiar thing, turned out to be generator brushes. If no electrical output, genny will shut down immediately. Less than 100 to have brushes replaced by a professional genny guy.
airshot is offline   Reply With Quote
Old 10-21-2019, 11:32 AM   #10
Member
 
Join Date: Sep 2019
Posts: 49
How do you test what the output is? Just on the plug? Will it output power while it's trying to start.
__________________
new to me 1997 Pace Arrow 30
always a work in progress
Joestein is offline   Reply With Quote
Old 10-21-2019, 05:23 PM   #11
Senior Member
 
George Schweikle's Avatar
 
Join Date: Apr 2004
Posts: 2,589
My 4K Onan had the same symptom in April. An Onan shop replaced the circuit board. Again in Sept. and this time it was worn brushes. This is a relatively new generator that I bought because I didn't want to spend lots of money to repair a 1999 Onan with a shorted rotor / stator. C'mon Honda, offer a built in RV generator as an alternative to Onan.

Quote:
Originally Posted by airshot View Post
Mine did a similiar thing, turned out to be generator brushes. If no electrical output, genny will shut down immediately. Less than 100 to have brushes replaced by a professional genny guy.
__________________
George Schweikle Lexington, KY
1999 Safari TREK 2830, FMCA 190830, Safari International chapter
1995 Safari TREK 2630, 1983 Winnebago Chieftain, 1976 Midas Mini
George Schweikle is offline   Reply With Quote
Old 10-21-2019, 05:54 PM   #12
Member
 
Join Date: Sep 2019
Posts: 49
It is out of a 97 pace arrow. I don't want to spend a couple Grand on a new one, and don't want to spend a grand on repair to find out I need a new one. I'm cheap, so rather at least try and figure out if it's worth it to fix.
__________________
new to me 1997 Pace Arrow 30
always a work in progress
Joestein is offline   Reply With Quote
Old 10-21-2019, 11:40 PM   #13
Senior Member
 
Jim.B1's Avatar
 
Join Date: Nov 2017
Posts: 672
I would suggest that it was not started regularly and the fuel in the carb has gummed up.
Today's fuels will go unstable in 30 days and will gum up your carb.
Try adding 1 -2 bottles of injector cleaner into the gas tank and allow it to get into the carb and clean the injectors.
You may also need to spray "Fire Starter" directly into the. carb just to get it started.
After you get it running, add fuel stabilizer to the tank if the genny is not going to be used under a load for any period of time.
__________________
Jim.B
Southern Ontario
2014 Fleetwood Southwind 32VS 🇨🇦
Jim.B1 is offline   Reply With Quote
Old 10-21-2019, 11:50 PM   #14
Senior Member
 
Join Date: Jun 2017
Posts: 1,767
Quote:
Originally Posted by Joestein View Post
I am having issues with my on board generator. It is an ONAN 4k microtite model E. I have replaced the carb, fuel pump and delivery is working, fuse and breaker is good. I can try and start and it seems to want to start, but shuts off as soon as i let go of start button. I have tried to disconnect the wire for the oil sensor, no luck. I have tried oil level filled on low side and high, no luck. It is a new to me motorhome and this is one of the main things that i cant figure out. Since it is in the motorhome it makes it slightly tougher to work on, so detailed instructions help a bunch. Any help would be amazing.
Quote:
Originally Posted by Jim.B1 View Post
I would suggest that it was not started regularly and the fuel in the carb has gummed up.
Today's fuels will go unstable in 30 days and will gum up your carb.
Try adding 1 -2 bottles of injector cleaner into the gas tank and allow it to get into the carb and clean the injectors.
You may also need to spray "Fire Starter" directly into the. carb just to get it started.
After you get it running, add fuel stabilizer to the tank if the genny is not going to be used under a load for any period of time.
__________________

tfryman is offline   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make old Onan Generator a Auto Start Version How I Installed Onan Energy Command 30 E ktoutoor RV Systems & Appliances 0 07-16-2019 12:15 AM
2006 Travel Supreme Select 500hp Cummins, 1200 ONAN generator generator d or will no Bev51 Travel Supreme Owner's Forum 4 06-13-2018 07:23 PM
Onan 6.5 Onan Emerald Plus Fuel Filter Afubar RV Systems & Appliances 13 01-13-2016 09:40 PM
What's the difference: Onan 5.5 Marquis Gold, Vs. Onan QG 5.5? 1943D18 RV Systems & Appliances 2 05-07-2013 02:22 PM
Retrofit Onan Carb with Commercial Onan Fuel Injection? DrLew iRV2.com General Discussion 10 01-23-2012 10:34 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×