Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-15-2014, 11:00 AM   #1
Junior Member
 
Join Date: Aug 2010
Posts: 4
Pheaton2012 windshield wiper no workinb

Our rv wipers just stopped working on our cross country trip. They were working just before we stopped to ge fuel and I washed the windshield. I pulled the blades out away from the windshield and put them back after washing. Back on the road and now neither one work. We've checked fuses and they are good. No repair available in our area. What else can we check?
__________________

__________________
Antiquechild is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-15-2014, 07:18 PM   #2
Senior Member
 
dvmweb's Avatar
 
Join Date: Sep 2010
Location: MI
Posts: 982
Well,
Check continuity of wires to wiper motor, switch and then the switch itself. And power from battery on. If that is all good maybe put a jumper on the wiper motor to make sure it works.




2013 FleetWood Expedition 38B
__________________

__________________
dvmweb is offline   Reply With Quote
Old 09-15-2014, 07:29 PM   #3
Member
 
jroan's Avatar
 
Tiffin Owners Club
Join Date: Jan 2012
Location: Pearl Mississippi
Posts: 90
Will they work when push to wash is selected? Or intermittent?

Jroan
__________________
Jerry & Anna
Retired Navy - 55 yrs Aircraft Mechanic/Pilot
2007 40 Ft Tiffin Phaeton, 2016 Ford Explorer
jroan is offline   Reply With Quote
Old 09-16-2014, 07:18 PM   #4
Junior Member
 
Join Date: Aug 2010
Posts: 4
No movement when on or when button is pushed to wash windshield. Not liquid is disputed either.
__________________
Antiquechild is offline   Reply With Quote
Old 09-16-2014, 07:27 PM   #5
Junior Member
 
Join Date: Aug 2010
Posts: 4
Thank you we can try the jumper on the motor but tracing the wire is too difficult to try on the road ourselves. Too many wires and little access to the dash switch area. But we used it to clean bugs from windshield just a few minutes before it wouldn't work. Only thing was I pulled the rubber part away from the windshield to clean when we stopped to get diesel. Immediately after starting motor the wipers would not work.
__________________
Antiquechild is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wiper Arm gjstacy Alpine Coach Owner's Forum 0 08-08-2014 06:55 PM
ACE 29.2 windshield wiper problem perrotcamper Thor Industries Owner's Forum 1 08-01-2014 12:31 AM
Wiper goes off the windshield Drivers Side. dnystrom Winnebago Industries Owner's Forum 6 07-14-2014 06:33 AM
2014 33.2 Windshield Wiper Inserts Replacements Dvillalo Palazzo Motorhomes 9 03-10-2014 07:41 PM
Windshield wiper problem bmeyer04 Workhorse and Chevrolet Chassis Motorhome Forum 2 10-09-2013 08:17 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.