Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-05-2016, 08:44 AM   #1
Junior Member
Join Date: Jul 2016
Posts: 2
Please help with no high speed blower motor.

Hello everyone. My parents are in their 80's and I am going to take them on a trip in their 1983 Fleetwood Pace Arrow to Iola, WI tomorrow. After spending a week prepping the unit and getting everything fixed the only thing left is I have no high speed on the dash blower motor. Low speeds work fine. I found the resistor pack OK. and have jumped 12v directly to the blower and it works fine that way. I hear people talking about a high speed blower relay that operates the blower when it's in HIGH mode, but I cannot seem to find it. Any help is appreciated.

scrid is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-05-2016, 09:00 AM   #2
Senior Member
Join Date: Sep 2014
Posts: 1,034
Can't help with that but .....do you have a generator that works?

If so, than you could run the rooftop AC while on the road.

1998 Tioga Class C
400 amp/hrs solar, Trimetric
Retire 2020 GLW
okcnewbie is online now   Reply With Quote
Old 07-05-2016, 09:02 AM   #3
Senior Member
Tiffin Owners Club
Freightliner Owners Club
Join Date: Aug 2014
Posts: 1,672
Others have posted that there is a separate fuse for high speed.
It might be an inline fuse.

2014 40QBH Phaeton DP Cummins 380HP ISL, Freightliner XC, 2014 Jeep Trailhawk TOAD
Blue Ox Aventa tow bar, SMI Air Force One -South Orange County Ca.
dpinvidic is offline   Reply With Quote
Old 07-05-2016, 09:04 AM   #4
Junior Member
Join Date: Jul 2016
Posts: 2
okcnewbie, Thanks. The GEN does work and we have done that in the past however it seems when driving down the road the wind sucks the life out of the roof air unit and it doesnt perform well. Sitting still and it will freeze you out of the cabin.
scrid is offline   Reply With Quote
Old 07-05-2016, 06:54 PM   #5
Junior Member
Join Date: Jan 2014
Posts: 16
Had the same problem....resistor pack was fine...turned out to be a burned wire right behind the switch.
cueball is offline   Reply With Quote
Old 07-06-2016, 06:15 AM   #6
Senior Member
epj's Avatar
Join Date: Nov 2014
Posts: 156
Originally Posted by dpinvidic View Post
Others have posted that there is a separate fuse for high speed.
It might be an inline fuse.

This is how most automotive blowers are wired. Should be a 30 amp fuse if memory serves.

2005 Phaeton 40'
epj is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower Motor - No high speed Ronbstewart Monaco Owner's Forum 17 07-20-2016 03:57 PM
Another blower high speed only post! dc8cappie Winnebago Industries Owner's Forum 31 09-07-2010 07:27 AM
heater/ac blower motor high speed not working Big Newf Dog MH-General Discussions & Problems 10 07-31-2007 07:48 PM
Only high speed working on my dash blower Ken & Joyce Winnebago Industries Owner's Forum 9 01-14-2007 03:37 PM
Only high speed working on my dash blower New Member Check-In 9 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:23 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.