Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-05-2016, 06:30 PM   #1
Junior Member
 
Join Date: Jun 2016
Posts: 4
Power Gear Mystery

We have a 2005 Fleetwood Providence Spartan chasis with power gear hydraulic jacks. Have replaced touch pad and brain box andfloat valve. When turned on the on and weight buttons flash and nothing happens. When auto and manual buttons are pressed nothing happens. When all retract is pressed the jacks down light comes on, then I pressed auto and sometimes 2 jacks go down sometimes 4 and they sometimes don't stay down. When I jump a wire at pump they work as they should individually. All wiring connections and grounds checked and cleaned. Any help in this matter would be greatly appreciated.
__________________

__________________
rvalfatravel is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2016, 05:57 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Hello and We are glad to have you join us here and we look forward to reading of your adventures and experiences. I am sure you will enjoy our website and forums. Good luck, stay safe and keep us posted.

Start by setting the Zero Point calibration https://www.lci1.com/assets/content/...alibration.pdf
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 06-06-2016, 08:09 AM   #3
Senior Member
 
American Coach Owners Club
Join Date: Feb 2000
Location: Oxford, Conn & Davenport,Florida
Posts: 414
Quote:
Originally Posted by rvalfatravel View Post
We have a 2005 Fleetwood Providence Spartan chasis with power gear hydraulic jacks. Have replaced touch pad and brain box andfloat valve. When turned on the on and weight buttons flash and nothing happens. When auto and manual buttons are pressed nothing happens. When all retract is pressed the jacks down light comes on, then I pressed auto and sometimes 2 jacks go down sometimes 4 and they sometimes don't stay down. When I jump a wire at pump they work as they should individually. All wiring connections and grounds checked and cleaned. Any help in this matter would be greatly appreciated.
You have 2 problems here,,,,Fleetwood and Spartan and neither one will step up to the plate to help you....each will tell you it is the others one causing the problem....GOOD LUCK
__________________
2017 45 FT Newmar Mountain Aire Seville Freightliner..with a 2015 Granite Grand Cherokee
Limited....GO NOLES
2012 American Tradition Merlot-Spartan>>SOLD
chuckster52 is offline   Reply With Quote
Old 06-06-2016, 08:52 AM   #4
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 4,517
Quote:
Originally Posted by chuckster52 View Post
You have 2 problems here,,,,Fleetwood and Spartan and neither one will step up to the plate to help you....each will tell you it is the others one causing the problem....GOOD LUCK

I must have missed read how did Fleetwood and spartan and don't forget power gear which would be the most help. I would contact power gear you will need to email and they will contact you back.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is online now   Reply With Quote
Old 06-06-2016, 12:17 PM   #5
Junior Member
 
Join Date: Jun 2016
Posts: 4
Quote:
Originally Posted by RV Wizard View Post
Hello and We are glad to have you join us here and we look forward to reading of your adventures and experiences. I am sure you will enjoy our website and forums. Good luck, stay safe and keep us posted.

Start by setting the Zero Point calibration https://www.lci1.com/assets/content/...alibration.pdf
What happens after #9?
__________________
rvalfatravel is offline   Reply With Quote
Old 06-06-2016, 12:45 PM   #6
Junior Member
 
Join Date: Jun 2016
Posts: 4
What happens after #9? We go thru the process as described and after #8 and about 15 seconds "all" the lights start flashing again and the legs all come back up. We have "new" parts all around on the Power Gear system.
__________________
rvalfatravel is offline   Reply With Quote
Old 06-06-2016, 02:06 PM   #7
Senior Member
 
ChasA's Avatar
 
Join Date: Mar 2007
Location: Apex, NC
Posts: 1,857
The resetting the system by your off the power to the unit for 5 minutes. On my coach the jacks are powered by the chassis batteries and fortunately I have a disconnect switch for both chassis and house batteries. If you don't have a switch, you can just disconnect the ground cable from the appropriate batteries. In the 4 years I've had this coach, I've had to do this twice.
Another point is that my Power Gear jacks to put into manual mode the manual button must be held down for 5 seconds. Also, the jacks always work in pairs, never individually.
__________________
2010 Winnebago Journey Express 34Y
2010 Freightliner XCS (mfd 9/'09)
'07 Saturn Vue V6
ChasA is offline   Reply With Quote
Old 06-07-2016, 05:50 AM   #8
Junior Member
 
Join Date: Jun 2016
Posts: 4
Thanks for all the help, still working at it. Im headed down the neutral safety switch trail with help from Lippert.
__________________

__________________
rvalfatravel is offline   Reply With Quote
Reply

Tags
power, power gear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear pump gear. Zonecone MH-General Discussions & Problems 10 04-27-2016 09:00 PM
Power Gear (now Lippert) pinion gear shaft bushing failure cruizerEd Winnebago Industries Owner's Forum 21 03-09-2016 12:23 PM
Power Gear slideout gear removal dirko MH-General Discussions & Problems 1 10-09-2014 11:19 PM
Power gear leveling gear no power BoPeg MH-General Discussions & Problems 5 05-22-2012 10:22 AM
Power Gear slide gear box---help! Ragman MH-General Discussions & Problems 6 06-20-2006 05:38 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.