Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-06-2011, 09:46 PM   #1
Junior Member
 
Join Date: Sep 2011
Posts: 2
Power Gear won"t lower the jacks

My leveling jacks won't activate because the system thinks the brake isn't on, but it is, and holds the coach. Any suggestions/diagrams appreciated. I have a 2006 HR Ambassador. Don Freeman
__________________

__________________
donfreeman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-06-2011, 09:57 PM   #2
Member
 
Join Date: Aug 2011
Posts: 79
Check the wire that hooks to the the parking brake switch, have seen several come loose over the years.
__________________

__________________
rv.guru is offline   Reply With Quote
Old 09-06-2011, 10:04 PM   #3
Junior Member
 
Join Date: Sep 2011
Posts: 2
Thanks, RV.GURU. Will try that next. Don
__________________
donfreeman is offline   Reply With Quote
Old 09-06-2011, 10:13 PM   #4
Member
 
Join Date: Aug 2011
Posts: 79
Giddie up let me know if that fixes it!!!! Good luck and happy camping!!!!!
__________________
rv.guru is offline   Reply With Quote
Old 09-07-2011, 04:46 AM   #5
Senior Member
 
Bo Walker's Avatar
 
Winnebago Owners Club
Join Date: Sep 2011
Posts: 240
This happens with mine sometimes. I simply release the park break and re-apply again and again. I also try removing the shifter from park and back into park. Something always works out.
__________________
Me & my Hun RVing for fun!
Bo Walker is offline   Reply With Quote
Reply

Tags
jacks, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear pump barbil Monaco Owner's Forum 3 07-29-2011 09:20 PM
Power Gear Jacks BDStinson Fleetwood Products Owner's Forum 17 06-29-2011 07:37 PM
Bounder: power gear Jacks ToddGaddy Fleetwood Products Owner's Forum 17 03-22-2011 09:16 AM
power gear stabilizer jacks ToddGaddy Fleetwood Products Owner's Forum 1 03-19-2011 06:11 PM
Power Gear Jacks VietVet Fleetwood Products Owner's Forum 55 07-02-2010 02:06 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.