Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-26-2010, 10:30 AM   #1
Junior Member
 
Join Date: Nov 2010
Posts: 5
powertec generator problems

I have a 10kw powertec generator,1999 model. when I try to start it, it will preheat normally then automatically try to start, but after about 3-4 seconds it will stop and the lite will go out on the generator switch, I will have to go outside and open up the generator housing and remove a fuse on the panel ,then put it back in and it will then try again for another 3-4 seconds then go into the same state again. The fuse is not bad but just removing it and reinstalling it will reset something but if it doesnt start in the 3-4 seconds then I must go outside and manually reset it. Outside temps around 20-40 degrees I suppose I may have some gloplugs that are not preheating because it will try to start but not do it before it starts all over again. When in the lower altitudes and warmer temps it starts and runs fine. Dont see the same problem. I also would like to know how to check glo plugs to see if thy are OK. anyone have any ideas? Thanks in advance.
__________________

__________________
medlin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-29-2010, 07:05 PM   #2
Senior Member
 
Jimmyzw22's Avatar
 
Join Date: Jan 2010
Location: Tracy, CA
Posts: 239
How many hours are on it? It really sounds like a clogged fuel filter to me, it is acting the same as mine did last year. New fuel filter took care of it right away.
__________________
2002 Holiday Rambler 40 PBT
Jimmyzw22 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.