Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2012, 10:24 AM   #1
Senior Member
 
catonine's Avatar
 
Fleetwood Owners Club
Join Date: Apr 2009
Posts: 426
Problem with pe emspt30c

I have the above surge protector and up until today it has worked well. Today it cut the power to MH and showed an error code of open ground. I checked plug and it was all ok, even had the CG maint. man check it and all fine. I plugged unit back in and it worked for a few minutes but made a humming noise. Soon after that it cut off again. I called PE and the tech said the unit sounded like it was fine and that the pedestal was bad. We talked about and tried a few things he recommended. I got it working again then the humming started and soon it shut off. I have a fellow camper near me that has the same unit and he brought his over and it worked fine. Any ideas before I call PE tech again?
__________________

__________________
John- 2011 Fleetwood Southwind 32V
catonine is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-14-2012, 10:44 AM   #2
Senior Member
 
nightriderrv's Avatar
 
Fleetwood Owners Club
Join Date: May 2012
Location: NC
Posts: 1,682
Maybe your unit has a problem or going bad was it hit from a storm and tripped because if the person next door hooked into your pole and it ran fine that might be the answer is it still covered under warranty
__________________

__________________
Mark Anderson - Nebo NC - western NC - RV Restoration tech - 9 Doggies - Outdoors person
1990 33ft Wilderness Cimarron 33X
nightriderrv is offline   Reply With Quote
Old 07-14-2012, 03:29 PM   #3
Senior Member
 
catonine's Avatar
 
Fleetwood Owners Club
Join Date: Apr 2009
Posts: 426
No storm came thru. The unit has a lifetime warranty. I talked to the tech at Progressive and told him that after checking the pedestal again, this time using another unit like mine and all being fine, that it had to be the unit failing. I had already checked the pedestal with my meter and the maint. man had as well. I think that the unit just had some sort of internal failure for some reason. I could get it to work for short periods but it was humming pretty loud and got very hot to the touch. I am sending the unit back to PE first thing Monday. They have exceptional customer service and the warranty is one of the best.
__________________
John- 2011 Fleetwood Southwind 32V
catonine is offline   Reply With Quote
Old 07-14-2012, 03:50 PM   #4
Senior Member
 
nightriderrv's Avatar
 
Fleetwood Owners Club
Join Date: May 2012
Location: NC
Posts: 1,682
They always been good I use only there products they will send you a new or repair the one you have just be careful without it in line, don't think twice about yanking that power cord out of the pole if a storm is coming
__________________
Mark Anderson - Nebo NC - western NC - RV Restoration tech - 9 Doggies - Outdoors person
1990 33ft Wilderness Cimarron 33X
nightriderrv is offline   Reply With Quote
Old 07-14-2012, 07:32 PM   #5
Senior Member
 
catonine's Avatar
 
Fleetwood Owners Club
Join Date: Apr 2009
Posts: 426
Thanks nightriderrv. I have also used only their products. This is the first time I had any problem but they were Johnny on the spot to try and help. The Tech I spoke with was outstanding. And yes, I will pull the plug in a heart beat. I learned that the hard and expensive way. Progressive now has lifetime warranty on their products. The way I understand it this covers even their product sold earlier. They are a stand up company and have great customer service. This is why Rver's give them such high marks.
__________________
John- 2011 Fleetwood Southwind 32V
catonine is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.