RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-15-2019, 08:41 PM   #1
Junior Member
 
Fleetwood Owners Club
Join Date: Oct 2019
Posts: 5
Problem with the BCC coach disconnect

Members, need some help.

My Pace Arrow coach battery disconnect is not activating power when the coach engine is OFF or connected to a shore, I don't get power at the Battery Control Center monitor(screen its off) above the entry door, nor light fixtures inside the coach. Both chasis & house batteries are fully charged (13.5amp). when I press the disconnect switch to ON I hear a clicking sound at the BCC box at the outside compartment but I don't get nothing inside the coach. I checked fuses at the BCC box but no burned out fuses. BUT, when I start the coach engine seconds later I get power in the coach, BCC monitor info lights up and all lights turn on. I also started the generator while engine is still ON to keep battery charge but once I turn the engine OFF seconds later lights go OFF and the generator turns OFF as well. I have connected the coach to a 50amp shore the micro starts, tvs, outlets and satellite but no coach lights. Is the problem the battery disconnect solenoid, board or something else? Help..
__________________

SalA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-15-2019, 09:49 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 19,674
I don't think its the battery disconnect. Starting the engine adds the chassis battery to the house battery and things work.

I would look at the house battery cable connections and the ground cable where it bolts to the chassis.

There should also be a breaker or fuse within a foot or 2 of the house battery.

To test the battery disconnect, start the engine to get the lights working. Then set the battery disconnect to OFF and see if the lights go out. Then switch it to ON and see if they come back on.
If they do, the switch is working fine. Your not getting house battery power to it.

One other point. If your meter is showing 13.5 Volts with the shore power plugged in, that's not the battery voltage reading, its the charger voltage reading. Pull the plug and read the volts.
__________________

twinboat is online now   Reply With Quote
Old 10-16-2019, 01:39 PM   #3
Junior Member
 
Fleetwood Owners Club
Join Date: Oct 2019
Posts: 5
Twinboat,
I searched for the fuse on the house batteries cable and no sight off one. It looks like the cable goes from batteries box straight to the Disconnect relay. Regretfully, I’m going to have to take it to the shop. Oh well.
SalA is offline   Reply With Quote
Reply

Tags
bcc, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BCC and lack of coach charge with engine running kennyrodgers Fleetwood Owner's Forum 0 05-18-2017 12:37 PM
Intellitec BCC & Battery Disconnect Relay BeachRV MH-General Discussions & Problems 3 04-01-2017 07:37 PM
Battery Disconnect problem, 2006 Hurricane 34N with FW-0675 BCC made by Intellitec. Stainsy Thor Industries Owner's Forum 3 07-13-2015 03:02 PM
No 12 volts in Coach. 12 to BCC - stops there I guess. Rstefani Thor Industries Owner's Forum 2 07-27-2014 02:40 PM
Thor Motor Coach Recalls 8,535 for Battery Control Center (BCC) DriVer RV Industry Press 13 10-25-2013 06:47 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×