Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-15-2013, 08:32 AM   #1
Member
 
Join Date: May 2013
Posts: 56
Problems with motorhome

Well, we were on our way to Washington from California when we encountered problems. We had the AC give us problems when we got to Klamath Falls and also a smell like rotten eggs. We had our dog and at with us and felt it would be best to drive back home. We left about 11:00 pm this last Sat. Night and drove all night back to California. We arrived back home yesterday, Sunday, at about 1:00 pm. One issue, my husband thinks, might be the batteries overcharging and boiling over causing the smell and also the converter. He is going to look into it. When we called the owners of the KOA Sat. Night, they came right out and tried to he. They were very friendly, but could not help but were very understanding and said they would credit us 1 night. It was a very small, crowded park and we had to fight Mosquitos just to hook up the car and it was dark. Mosquitos got into the MH and all over us. Then, we got home and found we had no water. Neighbor had shut it off as there was water bubbling up from around the main pies in front of house. Had to call the plumber and he came out and set it up tosh ere we had water and he is coming back today to replace some pipes. When it rains, it pours.
__________________

__________________
6jsgrandma is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-15-2013, 10:13 AM   #2
Senior Member
 
Join Date: Jul 2011
Posts: 942
Yes, we've had trips like that too. I'm sorry you had to have the experience. These motor homes are not fool proof. They are complicated and have complicated problems (sometimes). Many times they are simple problems packaged in a confusing manner. Posting your questions in the correct forum here may help. Good Luck! The smell of rotten eggs could also come from your gray-water tank.
__________________

__________________
2004 Tiffin Allegro 27.5 ft. P32 18,000 lb GVW. 8.1 liter. Workhorse chassis built May 2002. 21,000 miles. 2012 Jeep Liberty Toad. RVi2 brake unit.
Full.Monte is offline   Reply With Quote
Old 07-15-2013, 10:46 AM   #3
Member
 
papa peter's Avatar
 
Tiffin Owners Club
Join Date: Feb 2012
Location: California
Posts: 68
Quote:
Originally Posted by Full.Monte View Post
... Good Luck! The smell of rotten eggs could also come from your gray-water tank.
Had a similar issue a few weeks ago. Turned out that due to the heat, etc there was no water in the sink trap and that smell was coming from our gray-water tank. After doing some research, we poured some water in all the sinks and in the shower and it fixed it
__________________
2013 Tiffin Allegro RED 33AA
2012 Jeep Liberty Limited Jet
papa peter is offline   Reply With Quote
Old 07-16-2013, 08:51 AM   #4
Member
 
Join Date: May 2013
Posts: 56
Problems with MH

I hope this is the right place to post this. Thank you all for your suggestions. I will pass them on to my husband. Happy trails.
__________________
6jsgrandma is online now   Reply With Quote
Old 07-16-2013, 09:02 AM   #5
Senior Member
 
Workhorse Chassis Owner
Join Date: May 2006
Location: Holland, MI
Posts: 470
We don't have a crystal ball to know what problems you are having. Post the problem, what MH & chassis you have, and your location for help.
__________________
1995 Roadtrek 19 Versatile
Dodge 318
1975 GMC Eleganza II
bsinmich is offline   Reply With Quote
Old 07-16-2013, 09:11 AM   #6
Senior Member
 
clyon51's Avatar
 
Monaco Owners Club
Join Date: Mar 2012
Location: Arizona West RV Park, Yuma, Az
Posts: 4,117
I have a crystal ball, it's just my batteries are dead

Plenty of people to help you, but we need specifics. Make, model, year, and chassis (Ford, Workhorse, ect) of RV and the exact symtoms and problems you are having.
__________________
John & Clare Lyon
2007 43.5' Monaco Dynasty Palace III (All Electric)
Towd: 2011 Chevy Equinox
clyon51 is offline   Reply With Quote
Old 07-16-2013, 09:21 AM   #7
Senior Member
 
Hooligan's Avatar
 
Freightliner Owners Club
Join Date: Apr 2002
Location: Pensacola
Posts: 2,209
Quote:
Originally Posted by bsinmich View Post
Post the problem, what MH & chassis you have, and your location for help.
The OP was here: http://www.irv2.com/forums/f59/probl...me-168578.html

6jsgrandma- At the bottom of your "post" is a box to select post reply. It will put your reply in the same thread as your original question.
Hopefully you will get more replies...I think the batteries are a good possibility..post again if you have more info....
__________________
Hooligan, Pensacola, Fl -U.S. Coast Guard 1956-1985
2016 Thor Siesta Sprinter 24ST diesel
Our Pug "Lily" & "George" the Newfoundland
Hooligan is offline   Reply With Quote
Old 07-17-2013, 05:28 PM   #8
Member
 
Join Date: May 2013
Posts: 56
So very sorry. We have a class A 2002 Coachmen Rondezvous 34'. Thank you.
__________________
6jsgrandma is online now   Reply With Quote
Old 07-17-2013, 06:12 PM   #9
Moderator Emeritus
 
SarahW's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: In a lawnchair
Posts: 11,204
I have merged the two threads into one to avoid confusion. Good luck to the OP; hope you get the issue resolved.
__________________

__________________
.2012 Fleetwood Bounder 33C | 2012 Jeep Wrangler

SarahW is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.