Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-08-2011, 12:13 PM   #1
burmashave's Avatar
Join Date: Apr 2011
Posts: 71
Problems with service @ American RV

Thought I would share this so as to hopefully spare you all some of this. Took my 2001 Mitsubishi Eclipse Spyder GT to American RV in Flint yesterday to have a Blue Ox baseplate installed, wired for lights and adapter kit for the Demco tow bar I use. No Demco baseplate available for the Spyder. I drove home yesterday and discovered today:

1-the wiring was wrong with 2 leads transposed. fixed it myself cuz they are 40 miles away.

2-one headlamp burnt out.

3-front turn indicators not working-turned out the connector clips were left dangling.

4-one fog lamp out-too hard to get to, will try again on a dry day.

5-ram air box under hood not fastened back with factory grommets. No grommets at home so I used tie wraps for now.

6-two bolts on driver side headlamp replaced with non factory bolts for some reason. Not a big deal, but I would have preferred automotive bolts rather than hardware store just for appearances if nothing else.

7-tried to charge me $100 more for labor than was settled on over the phone when appt. was made. No real reason was offered for this, but they wound up charging me the agreed upon amount, but would gladly have charged me more had I been timid or not attentive.

Called American RV and was told to buy a headlamp and they would reimburse me. I called them back and told them the price, now they say they have to check with their boss for $19.06.

Keep in mind I was the only customer they were working for yesterday, (small shop I found online), and I waited patiently from 09:00 am to 12:30pm and never once asked how it was coming. So they can't use feeling pressured as any sort of excuse for not checking their work.

I for one will never go back there and if you value your time and money, you won't trust them with yours either.

Just an FYI.

burmashave is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-09-2011, 06:11 AM   #2
Senior Member
94-Newmar's Avatar
Join Date: Nov 2009
Posts: 2,043
There are several American RV places in Michigan it appears. Can you specify which one you used?

94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 04-09-2011, 07:43 AM   #3
Senior Member
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 21,176
Looking at what you went for and what your complaints are

The headlamp was very likely NOT their fault

The transposed wires were

The lack of baseplate... Well, did you have an appointment to have it installed or were you a "Walk in" customer?

The fog lamps and Turn signals.... It is possible ... Very possible, but frankly I don't know. Most likely it is their fault but I'm only about 80% sure, I've had problems like that without visiting any repair shop.

That said.. They should have checked those problems and caught them and notified you of the head lamp, and fixed the dngling clips.
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 04-09-2011, 08:47 AM   #4
burmashave's Avatar
Join Date: Apr 2011
Posts: 71
it was in Burton. The headlamp was working fine when I got there. They removed the headlamps from the nose to remove the fascia. I'm sure they dropped it. I was under the car again this morning. Unbelievable how many missing push lok clips. Others only partially pushed in. The turn indicator clips were just dangling when I found them. I clicked them in place and the indicator lamps were fixed. I had an appointment as I stated when I mentioned they tried to charge me $100 more than the quoted price when I made the appt.

must also be some misunderstanding. The lack of the baseplate was a Demco thing not being offered for my Spyder, and I knew it in advance, thus ordering the Blue Ox. The baseplate availability has nothing at all to do with the service/install issues, and I did not mean to infer it did. Sorry for that misunderstanding.
burmashave is offline   Reply With Quote
Old 04-09-2011, 08:58 AM   #5
Senior Member
Our Time's Avatar

Monaco Owners Club
Join Date: Aug 2006
Location: Ft Myers Fl / Omaha Ne
Posts: 617
Thanks for the heads up on this outfit. Please also post your review on www.rvservicereviews.com . You never know when a traveler will need service in that area, with your posting they will know what to expect.
Chuck & Mary
2008 Monaco Diplomat 40 SKQ
2008 Enclave Toad
Our Time is offline   Reply With Quote
Old 04-09-2011, 09:58 AM   #6
Senior Member
Finhawk's Avatar

Winnebago Owners Club
Freightliner Owners Club
Join Date: Jan 2008
Location: Olympia, Wa and Las Vegas, Nv for the Winter
Posts: 1,473
I hope you don't catch flak about this like I did last year when I posted about a Camping World experience. But it seems like one person has started already!
2012 Itasca Meridian 42E, Roadmaster Tow System, Unified Brakes on Toad
2011 Jeep Grand Cherokee Overland. US Army Armor. Ret
Finhawk is offline   Reply With Quote
Old 04-09-2011, 10:34 AM   #7
Senior Member
lllkrob's Avatar
Join Date: Nov 2008
Posts: 1,291
Sloppy workmanship is sloppy workmanship, no excuses. After the install everything they touched should have been checked and corrected. This is simply a lack of professional management that is prevalent in todays businesses

lllkrob is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Contemplating a 2000 American Dream, any advice on known problems I should look for Auzzi Fleetwood Products Owner's Forum 9 01-13-2011 06:40 AM
Power Monitor showing 50A service when on 30A service Yoda2405 RV Systems & Appliances 3 10-26-2010 03:08 AM
Thank You for your Service.... Seajay Military / Veteran RVing 2 09-04-2010 08:00 AM
Winnie Service at Forest City pegdiver Winnebago Industries Owner's Forum 2 05-05-2007 05:17 PM
Service Glenn and Kathy RV'ing Humor & Crazy but True Stories 3 10-17-2005 06:37 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.