Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-24-2016, 03:14 PM   #1
Junior Member
 
Join Date: Jan 2016
Posts: 2
Pulls left when hydro boost activates.

Hello to all .I need help with a brake issue.my MH is a 2000 CONDOR by R VISION on a p32 workhorse .It has 25,000 miles on it. Brakes work fine if applied gently to a smooth controlled stop. If a quick stop is made,it pulls left when the hydro boost activates. Steering is great, no lost motion. All Rubber brake lines replaced,all 4 calipers and brake pads replaced, fluid replaced in system . fluid is clear with no air bubbles. Jacked up front, both left and right wheels spin freely, both front calipers working and releasing correctly. Hydro boost seems to be working correctly, I can press brake peddle down then start the engine and it pushes the peddle upward against my foot. Help I'M STUMPED.
__________________

__________________
Shortbus32 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-24-2016, 03:20 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 9,877
Air in front tires the same pressure ?

Spring U bolts tight, center bolt good ? Front and rear ?

Spring hangers tight to frame ? Front and rear ?
__________________

__________________
twinboat is online now   Reply With Quote
Old 01-29-2016, 06:36 AM   #3
Senior Member
 
Damon Owners Club
Join Date: Dec 2012
Posts: 112
Your hydro boost as you describe it is working fine. The problem is in the left front. Are the caliper slides clean are the pins lubed properly are the pads seated properly something on the left side is not right. There should be a slight drag on the wheel with a new install, becoming free when fully seated. It can sometimes be hard to locate the exact problem. Good luck.
__________________
jsides is offline   Reply With Quote
Old 01-29-2016, 06:50 AM   #4
Senior Member
 
GraySeal65's Avatar
 
Country Coach Owners Club
Join Date: Jun 2013
Posts: 574
If it pulls left and it is the brakes then the problem is on the right side. The left is working fine and the right is less efficient. Re check everything, bearing torque, caliper slides, air in fluid, tire psi and never assume just because a part is new it's okay, 20% of the work I do comes back due to faulty parts.
As Twinboat said you could be dealing with a caster change under braking, did it do this before all the brake work was done ?
__________________
1997 Country Coach Intrigue Horizon 36' (The Dinosaur Burner)
GraySeal65 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't close left GE residential refrigerator door NorCal C&H Class A Motorhome Discussions 4 06-11-2015 10:58 AM
Turbo boost dropping on grades tom chelbana Cummins Engines 2 06-15-2014 04:28 PM
2002 Mountain Aire 38 foot gas Batt Boost circuit blows fuses mmstadler Newmar Owner's Forum 8 02-01-2014 08:59 AM
Boost and oil pressure sensors aztortuga Caterpillar Engine Forum 1 12-29-2013 10:37 PM
2000 Cummins ISC 350 Low Boost. crawbob Cummins Engines 61 12-26-2013 07:42 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.