RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-24-2018, 06:40 PM   #1
Junior Member
 
Join Date: May 2018
Posts: 2
Rear Lights Not Working When Towing

Greetings RVírs! Iíve benefited from reading many posts over the past 2 years. This is my first post and would very much appreciate any recommendations on the subject.

I have a 2005 Fleetwood Discovery and tiow a 2007 Hummer 3 using the Blue Ox/ Patriot Towing system. On my last trip, all of the rear lights on the RV quit working but all of the lights on the Hummer did work - brake, running and turn. The headlights and front turn signals work on the RV. Iím assuming there is a wiring harness under the Coach that separates the rear RV lights and the wiring plug to the toad. I havenít investigated too extensively at this point but would appreciate any feedback.
__________________

trippout is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-24-2018, 07:51 PM   #2
Senior Member
 
ThePowells's Avatar


 
Join Date: Mar 2017
Location: Zebulon, NC
Posts: 2,668

Welcome to the forum!



Trace your wiring back from the toad connection and then pull that apart and you will probably find corroded connections. If not, your coach may have a relay box for the toad connection. Look through your manual for a fuse for the "trailer connection".
__________________

__________________
Kelly and Jerry Powell with Halo (Lethal White Aussie), Nash the Rat Terrorist, and now Reid, the "Brindle we have no idea puppy"
2017 Thor Quantum W31, Ford E-450, Onan QG4000, Demco Kar Kaddy, Toytoada Prius.
ThePowells is offline   Reply With Quote
Old 05-24-2018, 09:04 PM   #3
Junior Member
 
Join Date: May 2018
Posts: 2
All of the Toad lights ARE working but NONE of the rear lights on the RV are working - brake, running, turn signal and emergency flashers.
trippout is offline   Reply With Quote
Old 05-24-2018, 09:09 PM   #4
Senior Member
 
ThePowells's Avatar


 
Join Date: Mar 2017
Location: Zebulon, NC
Posts: 2,668
Some systems will separate the coach from toad, but both of them will have a separate relay with a separate 5 or 10 amp fuse.



If not, I hope somebody will be along shortly who knows exactly how yours is wired and can tell you exactly what is wrong with no further effort.
__________________
Kelly and Jerry Powell with Halo (Lethal White Aussie), Nash the Rat Terrorist, and now Reid, the "Brindle we have no idea puppy"
2017 Thor Quantum W31, Ford E-450, Onan QG4000, Demco Kar Kaddy, Toytoada Prius.
ThePowells is offline   Reply With Quote
Reply

Tags
light, lights, tow, towing



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake, Tail and Rear Running Lights not working Purple tent Class A Motorhome Discussions 7 09-18-2016 05:36 AM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Motorhomes Owners Forum 3 02-26-2014 07:02 AM
bathroom fan, vanity lights, an one side overhead lights not working.. phillipsgj3 Monaco Owner's Forum 5 06-25-2013 06:03 PM
1990 right rear turn/hazard/brake lights not working MoHo2 Ford Motorhome Chassis Forum 2 08-10-2010 08:22 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.