Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2016, 03:59 PM   #1
Junior Member
 
Join Date: May 2015
Posts: 3
Remco transmission pump

Just got a remco pump to haul flat. my question is: Is it normal for the alarm (its the alarm that says low or no pressure) to sound for the first block or so when pulling the toad. also is it normal that that same alarm sounds whenever i make a tight turn, just for a few seconds but it freaks me out
__________________

__________________
docd55 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-18-2016, 04:05 PM   #2
Senior Member
 
Join Date: Mar 2013
Posts: 301
No not normal. Sounds like either the fluid level is low or the fitting in the pan is too high.
__________________
MotorPro is offline   Reply With Quote
Reply

Tags
transmission



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford/Remco Transmission Pump Issues Ssell Toads and Motorhome Related Towing 8 10-01-2016 08:11 AM
Flat towing using Remco transmission pump on Toad tom-brenda Toads and Motorhome Related Towing 30 04-22-2013 09:29 PM
Transmission Problems with Remco Pump? RVsteve Monaco Owner's Forum 3 06-26-2012 06:15 AM
Remco transmission oil pump shadowbj Toads and Motorhome Related Towing 2 08-22-2010 09:34 PM
Who is using a Remco transmission pump? RV 4 2 Toads and Motorhome Related Towing 8 11-27-2006 05:11 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.