Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-15-2012, 04:24 PM   #1
Member
 
Join Date: Jul 2011
Posts: 37
Shurflo water pump

I have this water pump that isn't running, I get 14 volts where the pump power comes in but I see what looks like a pressure switch that is part of the pump housing with the positive (red) wire coming from the input power line to the switch then another red wire coming from the switch to the pump motor. I am guessing the switch is stuck open but wondering if it is repairable? Anyone here done that yet? Was it worth it?
Thanks,
Bruce
__________________

__________________
Ham_Hog is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-15-2012, 07:01 PM   #2
Senior Member
 
4Knights's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Join Date: Jan 2011
Posts: 1,796
Quote:
Originally Posted by Ham_Hog
I have this water pump that isn't running, I get 14 volts where the pump power comes in but I see what looks like a pressure switch that is part of the pump housing with the positive (red) wire coming from the input power line to the switch then another red wire coming from the switch to the pump motor. I am guessing the switch is stuck open but wondering if it is repairable? Anyone here done that yet? Was it worth it?
Thanks,
Bruce
Bruce,
What type/brand/model pump is it? If you have 2 red leads coming off the head( square box on end of pump) it has a pressure sensor.
Read this thread
Shur flo 2088 403 144 just died any suggestions for replacement before next weekend?
Or this one.
Water Pump NFG

Your pump could be bad, your controller could be bad or you may have a restriction.
__________________

__________________
Ron & Wendy-Kansas
94 Pace Arrow 34 ft
25 yr Army retired 2006
4Knights is offline   Reply With Quote
Old 06-15-2012, 07:47 PM   #3
Member
 
Join Date: Jul 2011
Posts: 37
Shurflo pump..fixed(?)

Took the pump out and made a phone call to Shurflo customer service..parts are available but I decided to see if I could fix it and it turned out to be a bad micro switch was no longer working and I just happened to have a microswitch the same exact size, only difference was the contact, solder lug versus the spade lug..but all it took was a couple
of pigtail wires with spade lugs that mated with the existing female lugs.
Turned on power and I can hear the pump run..just have to try it with
water now, a minor detail, yeah right...
__________________
Ham_Hog is offline   Reply With Quote
Old 06-15-2012, 08:16 PM   #4
Senior Member
 
4Knights's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Join Date: Jan 2011
Posts: 1,796
Hope that fixed it! if not and you replace the whole pump make sure you get the higher amp controller at the same time.
__________________
Ron & Wendy-Kansas
94 Pace Arrow 34 ft
25 yr Army retired 2006
4Knights is offline   Reply With Quote
Old 06-15-2012, 08:45 PM   #5
Senior Member
 
LVJ58's Avatar
 
Join Date: Jul 2000
Location: Las Vegas, NV
Posts: 2,146
I highly recommend replacing it with a Flo-Jet Sensor VSD 4.5gpm pump. We've had one for several years now very dependable.

Good Luck
__________________
Jim & SherrySeward

2000 Residency 3790 v10 w/tags 5 Star tune & Banks system Suzuki XL7 toad
LVJ58 is offline   Reply With Quote
Old 06-15-2012, 09:05 PM   #6
Member
 
Join Date: Jul 2011
Posts: 37
Shurflo pump fixed

Thanks to all that replied, I will keep your recomendations on pumps but tested this pump with water and it is working ok so far..switching on and off as it should and water is flowing out of the faucets now.
__________________
Ham_Hog is offline   Reply With Quote
Old 06-16-2012, 11:27 AM   #7
Senior Member
 
LVJ58's Avatar
 
Join Date: Jul 2000
Location: Las Vegas, NV
Posts: 2,146
Glad to hear it's working OK now and thanks for the update.
__________________

__________________
Jim & SherrySeward

2000 Residency 3790 v10 w/tags 5 Star tune & Banks system Suzuki XL7 toad
LVJ58 is offline   Reply With Quote
Reply

Tags
water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.