Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 12-06-2015, 10:21 PM   #1
Join Date: Nov 2011
Posts: 37
SLIDE Sometimes no power WHY?

2004 Tiffin Alegro gas engine LOW milage.

Emergency Brake on. Ignition to ACC. House and Veh Battery full charge. LEVEL NOT IMPORTANT.

Neither front nor rear slide will open... assume no power.

At rear slide switch. EXPOSE. Run 12V positive wire from house battery. Touch pole #2 to exposed 4 plug/contact switch. Press open and it works. Front slide now also works. Can also send 12V positive to under bed slide motor... everything works.

Once energized will continue to work... until the next stop. Sometimes will work even then.

When something works sometimes and does not work sometimes not an easy concept to resolve.

Fiddling with ignition switch many time not a resolution. Parking brake on or off many times not a solution as simply giving mementary power to switch should not resolve with it working with momentary removed. Should not work at all if that was the issue.

Must be a simple answer.... like it was a cludy day...

anderson2624 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-07-2015, 03:42 AM   #2
Community Moderator
RV Wizard's Avatar

Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 11,812
Sounds like you have badly pitted points in the solenoid. If you have control voltage when switch(s) is activated and the solenoid energizes but no connection is made then bad points.

Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 12-07-2015, 06:15 AM   #3
Senior Member
luvlabs's Avatar
Tiffin Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 1,486
Give Tiffin Service a call. They can tell you which solenoid and where it is located. BTW, have you tried putting the slides out with the engine running? Your batteries, unless you are plugged into 50 amps, may just be too low to move anything.
Roger & Mary
2014 Tiffin Phaeton 36GH
2012 Honda Fit toad
luvlabs is offline   Reply With Quote
Old 12-07-2015, 09:36 AM   #4
Senior Member
gemini5362's Avatar
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Posts: 2,074
My allegro bus slides will not work with the key on. Have you tried doing it with the key in the off position
2005 Allegro Bus 38DP
2012 Enclave tow vehicle
No Dogs, No cats.
gemini5362 is offline   Reply With Quote
Old 12-07-2015, 10:27 AM   #5
Senior Member
Join Date: Jul 2014
Posts: 167
I'm not familiar with your slide system so my comments are general. Do you have 12 VDC to the switch? If not is that why you ran a jumper from the battery to it? If you have 12 VDC at the switch but you had to jumper across the switch (to the output side), then there's a good possibility that the switch itself is going bad. Those little rocker switches do arc and burn especially with DC voltage on them. If that happens, they can become notoriously intermittent, working fine so several actuations, and not working at all for many more.
navigator336 is offline   Reply With Quote

power, slide

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
no power to drivers side slide out conor12505 Fleetwood Products Owner's Forum 6 09-27-2015 10:24 AM
Front slide lacks power to retract bklaes Monaco Owner's Forum 18 06-20-2015 07:52 PM
Power Gear Slide Out replacement LMBraley Class A Motorhome Discussions 4 02-07-2015 07:18 AM
Slide won't go in, no power.... RDG Class A Motorhome Discussions 12 09-22-2014 05:09 PM
Closed Lippert Schwintek closet slide leak on Outdoors RV Wind River tredfield Outdoors RV Owner's Forum 9 07-05-2014 06:03 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:03 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.