Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-06-2011, 11:26 AM   #15
Junior Member
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Apr 2011
Location: Gilbert, Az
Posts: 4
Hi Snoweagle,
Thanks for the advise on clipping off the plastic connections on the slide motor. I did this and now my slide works fine. I can't belive Fleetwood doesn't know about this problem. I had my motorhome to several shops and even called Fleetwood on this issue and they could not get it right. Thank you again.

Irvon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-26-2011, 11:15 AM   #16
Junior Member
Join Date: Nov 2010
Location: Willis,Tx.
Posts: 14
You can also run your generator if your battery are weak,might help bring those slides in.My slides won't work with the motor running.

hwishard is offline   Reply With Quote
Old 08-26-2011, 07:54 PM   #17
Registered User
Fleetwood Owners Club
Join Date: Dec 2006
Location: Back in Philly for the fall heading to Sunshine before the snow flies
Posts: 1,485
Problem is with the driver side flush floor. When you retract the slide it must ride up to clear the floor inside. It's just a tapered piece on the front of the slide that does the work. These motors are minimal at best, running the genny won't help the engine needs to be running unless the engine batteries are really tip top shape. They came out with a higher torque motor but it's on your dime. If it gets too bad you can take it to a starter rebuilder and see if he can up the torque. I've heard of folks doing that. Good luck.
hondo122 is offline   Reply With Quote
Old 08-28-2011, 07:40 AM   #18
Junior Member
BDStinson's Avatar
Join Date: Sep 2010
Posts: 26
My '03 Excursion does exactly the same thing on the front driver side slide. The PO has already replaced the driver motor, but the problem still exists for me. I did hard wire the the connection at the motor and it helped a lot. I suspect the motor just doesn't have the torque to move the flush floor slide for long.
BDStinson is offline   Reply With Quote
Old 09-05-2011, 04:12 AM   #19
Junior Member
Join Date: Sep 2011
Posts: 1
I have a bounder 38N and have the oosite problem. I have to keep bumping the switch to get my slide to go out. Once it gets to a certain point it goes out fine.

Fixitroll is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Our New Ride - Fleetwood Excursion cirquegirl New Rig Show-Off! 19 12-14-2010 10:04 PM
Fleetwood Wilderness, Yukon, 24ft 2003 DianaBanana Travel Trailer Discussion 4 11-19-2010 12:22 AM
2008 Fleetwood Expedition Slideout dberthelot Fleetwood Products Owner's Forum 6 07-08-2010 08:22 AM
problems with 2003 fleetwood providence Taco MH-General Discussions & Problems 5 09-22-2005 03:24 PM
Fleetwood 5th wheel slideout repair problems? slideout 5th Wheel Discussion 1 01-01-2005 06:27 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:00 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.