Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-14-2017, 08:53 AM   #1
Senior Member
 
Join Date: Sep 2013
Posts: 364
Splendide wash cycles not working

Our Splendide ARWXF129W washer does not do anything on any wash cycle setting. You can hear a low level hum though but it does nothing. However, when selecting “A” for the rinse setting, it starts there at the rinse cycle and goes all the way through to the end. Anyone had this problem before? How can I get my wash cycles to work?
__________________

__________________
Mo Fred, South Central Missouri
2002 Beaver Patriot Thunder
C12 CAT 455 HP, 40 FT, Towing 2012 Mazda III
MO Fred is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-14-2017, 09:54 AM   #2
Senior Member
 
BrianGlenn's Avatar


 
Country Coach Owners Club
Join Date: Apr 2015
Location: Alberta
Posts: 963
Any fault codes displayed on the LEDs? Here is the AW129NA service manual. The fault code table (LED lights flashing) is near the back.

Westland Sales in Oregon helped me trouble shoot my Splendide washer and I ended up replacing my control board. They have the parts.

Hope this helps.
Brian
__________________

__________________
Towr: 2007 Country Coach Allure 470 - 37 Sunset Bay Cummins 400 ISL
Toad: 2016 F150 King Ranch - 3.5L EcoBoost 4x4 Supercrew (curb weight 4,775 lbs)
Toad: SOLD 2007 Jeep Grand Cherokee (yes, it has a Hemi) (curb weight 4,720 lbs)
BrianGlenn is offline   Reply With Quote
Old 12-14-2017, 07:56 PM   #3
Senior Member
 
Join Date: Sep 2013
Posts: 364
Quote:
Originally Posted by BrianGlenn View Post
Any fault codes displayed on the LEDs? Here is the AW129NA service manual. The fault code table (LED lights flashing) is near the back.

Westland Sales in Oregon helped me trouble shoot my Splendide washer and I ended up replacing my control board. They have the parts.

Hope this helps.
Brian
Thanks, sounds great! I will give it a try.
__________________
Mo Fred, South Central Missouri
2002 Beaver Patriot Thunder
C12 CAT 455 HP, 40 FT, Towing 2012 Mazda III
MO Fred is offline   Reply With Quote
Old 12-14-2017, 10:31 PM   #4
Senior Member
 
hawkeye1995's Avatar
 
Damon Owners Club
Join Date: Feb 2016
Posts: 204
Try unplugging for 2 minutes then plug back in. Anything that is computerized can be reset sometimes. We did this a friends LG Dryer. Worked perfect after that, and that was a year ago. It's worth a try.
__________________
2005 Damon Daybreak 3070 Workhorse P32 8.1 eng
Toad - 2006 Chevy HHR Flat Tow
Bluie Ox Tow System and Brakes
hawkeye1995 is offline   Reply With Quote
Old 12-15-2017, 08:31 AM   #5
Senior Member
 
WillandJane's Avatar
 
Join Date: May 2015
Location: San Jacinto, CA
Posts: 378
Splendide wash cycles not working

Quote:
Originally Posted by hawkeye1995 View Post
Try unplugging for 2 minutes then plug back in. Anything that is computerized can be reset sometimes. We did this a friends LG Dryer. Worked perfect after that, and that was a year ago. It's worth a try.


.....we had the same problem with ours. I gave up the trouble shooting after many attempts to get it working with Splendide. I finally took it into camping world and with them working with Splendide, they replaced the control board 2 times on the bench and did a few other changes as well with no luck. Finally Splendide authorized Camping World to give us a brand new one. They wanted the old one back for their own research and development. The new one hasn’t given us a problem in two years.

WDK
__________________
WillandJane is offline   Reply With Quote
Old 12-15-2017, 03:51 PM   #6
Senior Member
 
Join Date: Sep 2013
Posts: 364
Quote:
Originally Posted by hawkeye1995 View Post
Try unplugging for 2 minutes then plug back in. Anything that is computerized can be reset sometimes. We did this a friends LG Dryer. Worked perfect after that, and that was a year ago. It's worth a try.
Followed your advice and now it works! Couldn’t get behind it so I turned it off at the circuit breaker for a few minutes. We have washed 3 loads with no problems. Thanks!
__________________
Mo Fred, South Central Missouri
2002 Beaver Patriot Thunder
C12 CAT 455 HP, 40 FT, Towing 2012 Mazda III
MO Fred is offline   Reply With Quote
Old 12-15-2017, 04:00 PM   #7
Senior Member
 
450Donn's Avatar
 
Join Date: Jun 2006
Location: Dallas,OR
Posts: 2,572
Keep Westland Sales in Milwaukie,OR phone number handy. They are very friendly and helpful. They also have parts on hand, so you can have it fixed in a couple of days
__________________
450Donn is offline   Reply With Quote
Old 12-15-2017, 05:44 PM   #8
Senior Member
 
hawkeye1995's Avatar
 
Damon Owners Club
Join Date: Feb 2016
Posts: 204
Quote:
Originally Posted by MO Fred View Post
Followed your advice and now it works! Couldn’t get behind it so I turned it off at the circuit breaker for a few minutes. We have washed 3 loads with no problems. Thanks!
Glad it worked, strange how that works. I have done that on several electrical items. Sometime it works, sometimes it don't. Here is another little trick I learned. If you have a Direct TV Box plugged into a electrical strip, sometime you have to remove the plug from the strip and the box will start working again. Resetting the box and unplugging from the wall did nothing. Strange? Glad I could help. Safe travels.
__________________
2005 Damon Daybreak 3070 Workhorse P32 8.1 eng
Toad - 2006 Chevy HHR Flat Tow
Bluie Ox Tow System and Brakes
hawkeye1995 is offline   Reply With Quote
Old 12-16-2017, 12:44 AM   #9
Senior Member
 
JFXG's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: May 2012
Location: Today? Mercer, PA
Posts: 3,627
Westland will hopefully be able to help you. Their techs are sharp.
The Ariston line is an Australian brand (iirc) that was fairly recently acquired by the same parent corp that owns the Splendide brand (made in Italy). They're both in the same family now, but the Ariston is not a Splendide product. However, I have confidence that the Westland Sales support techs will have climbed the learning curve quickly.
__________________

__________________
John & Diane, Fulltimers. RVM103 NHSO
On the road since June '12 with Lincoln, the guard cat.
2002 Dutch Star 40, Freightliner, Cat 3126, 2004 Element
JFXG is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parts for older Splendide wash/dry combo JohnArch RV Systems & Appliances 7 09-18-2017 06:11 AM
Splendide (Vented) Wash/Dry Times TechWriter RV Systems & Appliances 4 06-29-2016 07:11 PM
Aero Wash/Wax system Waterless wash countrypair Gear and Product Discussions 25 03-21-2016 06:45 PM
Hand wash or power wash? jefrut iRV2.com General Discussion 20 05-17-2015 12:40 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 05:22 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.