Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-03-2016, 12:16 PM   #1
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
Tecma toilet

I have a tecma toilet in a 07 holiday rambler ambassador Motorhome.
I can't find the model but the control on the wall has two buttons, left one says water saver flush, right one says normal flush. My prob is when either is pushed water comes in normally but it won't flush. You can hear it click but nothing happens. I have tried everything I know to do like holding button for 8 seconds an holding both down at same time but always same result. Just the click sound. Voltage is fine also. No red lights are on. Both buttons are blue. Bottom right water symbol is green. Thanks
__________________

__________________
Hfg59 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-03-2016, 09:18 PM   #2
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
Never mind I figured it out.
__________________

__________________
Hfg59 is offline   Reply With Quote
Old 07-04-2016, 08:54 AM   #3
Senior Member
 
Join Date: Mar 2009
Location: Apollo Beach, FL
Posts: 1,520
... and the solution was ??????
__________________
2013 DS 4338
2015 F-150 toad with kayaks,bicycles and a Harley in the back
PanJH is offline   Reply With Quote
Old 07-04-2016, 10:29 AM   #4
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 4,517
Left button pee, right button poop both buttons in drains for driving and both in fills to your water level.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 07-04-2016, 07:51 PM   #5
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
I know how to operate it. It would not flush. I fixed it, thanks
__________________
Hfg59 is offline   Reply With Quote
Old 07-04-2016, 07:52 PM   #6
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
Impeller was plugged. Took it apart freed the impeller an it works fine.
__________________
Hfg59 is offline   Reply With Quote
Old 07-05-2016, 09:15 AM   #7
Senior Member
 
phil57's Avatar
 
Join Date: May 2012
Posts: 275
Quote:
Originally Posted by Hfg59 View Post
Impeller was plugged. Took it apart freed the impeller an it works fine.

I had the same issue. When personal wipes say flushable make sure your wife knows that it means at a S&B not the Moho.
It's a nasty job!
__________________
phil57 is offline   Reply With Quote
Old 07-05-2016, 09:24 AM   #8
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
Yeah I hear ya. Not really sure what it was. Is was very easy to free up. We will see how it works in the future. It was first run with this rig. I've never had this type of toilet, figure out as you go I guess. Thanks
__________________
Hfg59 is offline   Reply With Quote
Old 07-05-2016, 10:25 AM   #9
Senior Member
 
flaggship1's Avatar


 
Fleetwood Owners Club
iRV2 No Limits Club
Join Date: Sep 2012
Location: Rainbow Riding
Posts: 18,395
Quote:
Originally Posted by Hfg59 View Post
Yeah I hear ya. Not really sure what it was. Is was very easy to free up. We will see how it works in the future. It was first run with this rig. I've never had this type of toilet, figure out as you go I guess. Thanks
So far we've been lucky with ours. So if you pull the thrown - is the impeller visible? Not something I ever want to do but would like to know.
__________________
Steve & Annie (RVM2)
2008 Fleetwood Bounder 38F ~ 325 ISB Turbo ~ Freightliner XC 2014 CR-V ~ Invisibrake / Sterling All Terrain
Sioux Falls, SD (FullTime Since Nov 5th 2014)
flaggship1 is offline   Reply With Quote
Old 07-06-2016, 06:57 AM   #10
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
No it's in a plastic case. It has a little 12 volt motor attached to it that looks just like the motor on your water pump. I turned the toilet upside down to work on it. It really was not as bad I figured it would be.
__________________
Hfg59 is offline   Reply With Quote
Old 07-06-2016, 07:30 AM   #11
Member
 
Hfg59's Avatar
 
Join Date: Sep 2013
Location: Mustang ok
Posts: 83
When you take hose going into impeller housing off, the impeller is exposed. With a gloved hand I just turned it an freed it up.
__________________

__________________
Hfg59 is offline   Reply With Quote
Reply

Tags
ecm, toilet



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tecma Toilet Installation chkwgn MH-General Discussions & Problems 19 04-02-2010 11:21 AM
Thetford Tecma Toilet Sensor Issue Lukeaa RV Systems & Appliances 2 01-09-2009 10:30 PM
Tecma toilet JVR Class A Motorhome Discussions 5 11-28-2008 10:44 AM
Need Tecma Toilet Help Robin_M Monaco Owner's Forum 14 09-26-2007 09:07 AM
Tecma toilet RV Systems & Appliances 5 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.