Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-19-2016, 06:00 AM   #1
Join Date: Nov 2002
Location: Woodstock, Georgia
Posts: 43
Transmission problem

I hope this is not too vague.

We have a 2014 Fleetwood Excursion 33D with the 300 HP Cummins and (what I think is a) Allison 2500 transmission. We bought it new off the lot in March or 2016 and it's under full warranty. Either way, we are having problems.

Occasionally in the past, I've attempted to put it in drive by pressing the D button on the selector. Nothing happened. I presses the R button, felt it shift and saw the jump on the tachometer that indicated the shift. After a few seconds, I pressed the D button and it went right into drive. This happened several times, almost always on a 'cold' start up.

One time, the transmission shifted to neutral as I was driving through the cul-de-sac at the end of our street. It may have been in first gear. Kinda of freaked me out.

This was the real problem. A couple of trips after the driving shift to neutral, we attempted to leave a campground near our home. I pressed the D button and NOTHING happened. It would go into reverse but never into drive. I attempted several button presses and combinations but nothing happened. Finally after about 15 minutes or so, it shifted into drive and it went perfect all the way home.

A few days later, we took the RV to the camping world that had been doing the warranty work on other items (That is a completely different story and a perfect example of near incompetence). The RV started up fine and performed flawlessly the trip there, about an hour fifteen minute drive. When I asked the service writer if they cold look at it, the writer asked the service manager who said no, we would have to take it to Fleetwood.

I'm open to suggestions and will answer any relevant questions.

My thanks.

2014 Fleetwood Excursion 33D
2014 F150 4X4 (hers)-L
1985 F150 (his)-J
1988 Son (ours)
1990 Daughter (ours)

2006 E250 work van (ugh)

HeatAir is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-19-2016, 06:47 AM   #2
Junior Member
Join Date: Jun 2009
Posts: 10
If you have the 300hp cummins, then most likely you have the Allison 2100 transmission. If you want it fixed take it to Freightliner in Gafney, SC where it was, most likely, built. They do great work and also offer a 2 day class on the chassis, tranny, and engine. Great class and well worth the cost. I bought mine at Camping World and won't let them touch it.

rdchildr is offline   Reply With Quote
Old 09-19-2016, 07:10 AM   #3
Senior Member
johnhicks's Avatar
Join Date: Jan 2011
Location: Wandering below the Gnat Line
Posts: 343
W.W. Williams is the Allison distributor/repair in Georgia. W.W.Williams | Locations
CG reviews & more - www.fugawetribe.com
johnhicks is offline   Reply With Quote
Old 09-19-2016, 08:18 AM   #4
Senior Member
lakebuster's Avatar
Newmar Owners Club
Join Date: Aug 2015
Posts: 258
We were told to always hit neutral if going from D to R or vise-versa and to ensure it is in N before applying parking brake.
David and Sharon
2015 Newmar DS 4369
2015 Jeep Wrangler Willys Wheeler Edition (Toad)
lakebuster is online now   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
A40D transmission heats up then leaks but slow no problem women fly Ford Motorhome Chassis Forum 10 11-02-2014 07:23 PM
Standard transmission or Automatic transmission Aguyfromcalg Just Conversation 27 06-12-2011 10:16 AM
Transmission braking causes transmission breaking obbm Workhorse and Chevrolet Chassis Motorhome Forum 38 05-08-2010 07:05 PM
transmission overdrive problem James Cramphorn Ford Motorhome Chassis Forum 3 10-04-2008 07:30 AM
transmission problem Sumar Damon 8 05-22-2008 02:40 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:22 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.