Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-09-2016, 06:22 PM   #1
Senior Member
Smitty77's Avatar
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 2,394
TST 510 Tire Monitor - Wondering if it's dead?

I'll call TST for help on Monday, and I have read FAQ and Manuals with no luck.

I have a 5-6 year old TST 510 system with 12 tire monitors. The batteries in the sensors were sent to TST to have new batteries installed. (For sure, they just swapped them out with either new or refurb's - as they are all new 4 digit codes when they came back). (And, really neat people to deal with!).

I added put them into position, and programmed them into my coach and toad setup. All fired up fine, and no problems in getting the codes manually entered in. I say manually, as I monitor's embedded batteries seems to now be out too. I could not unplug from the 12V supply, to take advantage of the self programming feature that really speeds things up(:!.

Well now three weeks later, the monitor comes on, but no signals or readings are displayed. I've tried to remove a sensor and re-install it on the tire, to see if it would 're-engage' to the monitor. No luck. Even trying to turn the monitor off with power available (The "-" sign for 6+ seconds.) will not turn the monitor off.

OK, though I'll call the company on Monday. Anyone have any experience with this? I'm OK with the monitor's battery being dead. (And see no way to replace it(?)) But heck, if I had known the monitor would also have an end of life - I'd have upgraded to the newer monitor and 507 sensors. Vs paying for the 510 sensors replacement batteries. (Bigger screen, would have been nice. And the pass thru air of the 507 would have been another benefit!

Input appreciated! Best to all,

Roo II is our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-09-2016, 06:46 PM   #2
"Formerly Diplomat Don"
Dutch Star Don's Avatar
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 7,224
I think if you explain to TST your situation, you'll probably find that they will work with you to resolve your problem or upgrade you.

Don & Mary
2014 Newmar Dutch Star - All Electric - 450 ISL
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Old 04-09-2016, 06:59 PM   #3
Senior Member
Lv2Roam2's Avatar

Winnebago Owners Club
Freightliner Owners Club
Join Date: Jun 2014
Location: Somewhere On the Road
Posts: 304
I have a high suspicion index that your monitor is acting up rather than sensors. Perhaps a long duration charge of the monitor while turned off, followed by attempting operation while both plugged in and not may improve the system. If by chance there's someone close by that could share their monitor with you for a test could also help narrow down the problem. I've got the TST system - their customer service is very good ...
2015 Itasca Ellipse | 2014 Jeep Grand Cherokee
Lv2Roam2 is offline   Reply With Quote
Old 04-09-2016, 07:30 PM   #4
Senior Member
cdinatl's Avatar

Join Date: Jul 2013
Posts: 222
Just call TST and ask for Debbie. I bet she'll send you a new monitor at NC. They are fantastic people!!!

2008 Holiday Rambler PDQ Ambassador 360 ISC
2015 Jeep Rubicon
Blue Ox tow Patriot brake
cdinatl is offline   Reply With Quote
Old 04-09-2016, 07:32 PM   #5
Senior Member
Mr_D's Avatar
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 22,423
I've had two monitors go bad. In fact they wouldn't even power up when plugged in. TST swapped them out with no trouble or cost other than postage one way.
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '05 Odyssey
Mr_D is online now   Reply With Quote
Old 04-09-2016, 09:25 PM   #6
Senior Member
TonyDi's Avatar

Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 6,238
The people at TST are so great to work with. I wouldn't have any TPMS other then theirs.
I've had my TST507 for years an had no issues.

Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, Jeep Grand Cherokee,with Hemi, hooked up with a Blue Ox Aventa LX, and Brake Buddy.
TonyDi is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
TST 510 s cracking? tnteacherguy Gear and Product Discussions 10 07-02-2015 04:03 PM
TST Truck 510 TPMS Repeater jerichorick Toads and Motorhome Related Towing 5 04-12-2015 07:18 AM
TST model 510 Tire Monitoring System lajuene Technology: Internet, TV, Satellite, Cell Phones, etc. 34 05-13-2012 09:17 PM
TST TM-510 TPMS Long Antenna, Is it Needed on 40' MH sdennislee Class A Motorhome Discussions 20 10-04-2011 04:09 PM
TST: Help with TST tire monitoring system SC06Winn39K Winnebago Industries Owner's Forum 13 02-12-2011 12:03 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:51 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.