RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-11-2019, 06:18 PM   #1
Junior Member
 
Join Date: Jul 2018
Posts: 14
Voltage spike and speedo failure

Was heading to Road Atlanta on Friday from Charlotte and cruise control kicked out, batt light aluminates and voltage spiked for a few seconds. Speedo settled at <15>mph while cruising at 70. No engine issues but cruise control out, voltage back to normal.
Slowed down to near stop and everything was back to normal.
Happened 3 times. Trip back to Charlotte on Sunday, no issues at all ???
Any thoughts? Speed sensor possibly?
2000 Expedition with 5.9 cummins pusher.
Thanks for any thoughts.
__________________

Roadhogger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-11-2019, 06:37 PM   #2
Senior Member
 
1st-tt2018's Avatar
 
Thor Owners Club
Join Date: Oct 2018
Location: Virginia
Posts: 256
Sounds like a voltage regulator issue on alternator messing with voltge and kicking the ecm in the gut.
__________________

__________________
2019 coleman lantern 202rd
1st-tt2018 is online now   Reply With Quote
Old 09-11-2019, 07:10 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 18,612
Bad battery connections where the chassis battery power is switched to accesseries.

That or bad grounds.
twinboat is offline   Reply With Quote
Old 09-11-2019, 08:04 PM   #4
Senior Member
 
Hooligan's Avatar
 
Freightliner Owners Club
Join Date: Apr 2002
Location: Pensacola
Posts: 2,550
May not be related but the Freightliner chassis's in the 2000 era had problems with the VDC (Vehicle Data Computer) All data feeding the instrument cluster goes thru the VDC including the air pressures.
My 2000 Landau (Freighter XCS and Cummins ISB) would lose speedometer and voltage readings , sometimes also drop cruise but I did have speed and tach drop and cruise continue. Would ALWAYS reset after a short shutdown (rest area etc) and usually would not happen again for a few months...
My VDC was located in a rear compartment behind a panel but different chassis had other locations. I never had to repair mine but cleaned the electrical connectors on the VDC and VIM with good results. File here on IRV2 about the VDC. Can be downloaded.
iRV2 Forums - Files - VDU/ VDC Repair

This shows the VDC, TCM (Transmission computer) and VIM on my Landau.
__________________
Hooligan, Pensacola, Fl -U.S. Coast Guard 1956-1985
2016 Thor Siesta Sprinter 24ST diesel -1972 Moto Guzzi
Our Pug "Lily" & "George" the Newfoundland
Hooligan is offline   Reply With Quote
Old 09-11-2019, 08:17 PM   #5
Senior Member
 
Hooligan's Avatar
 
Freightliner Owners Club
Join Date: Apr 2002
Location: Pensacola
Posts: 2,550
More info on the Freightliner gauges and VDC

http://ww2.justanswer.com/uploads/go...44_sbu5412.pdf
__________________
Hooligan, Pensacola, Fl -U.S. Coast Guard 1956-1985
2016 Thor Siesta Sprinter 24ST diesel -1972 Moto Guzzi
Our Pug "Lily" & "George" the Newfoundland
Hooligan is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spike in 50 amp pwr cord rcoppock RV Systems & Appliances 3 05-07-2016 07:36 PM
AC amperage spike ramblinboy RV Systems & Appliances 4 03-31-2015 11:48 AM
Spike in electricity billing Marpie Class A Motorhome Discussions 14 07-30-2014 04:27 AM
Fuel filters Spike 45 96 Wideglide Cummins Engines 5 02-16-2014 09:02 PM
Spike, Water wetter DAJO Cummins Engines 1 01-07-2014 07:49 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.